MySQL Root - Max Quirers Per Hour - URGANT

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL Root - Max Quirers Per Hour - URGANT

Postby Neo13 » 28. May 2006 17:40

EDIT:
Error is:
.#1226 - User 'root' has exceeded the 'max_questions' resource (current value: 10)

Urgant error!

I accidently set for user account "root" max quieres 10 per hour. now soon as i load up sql it already reaches the max.

I havnt added anymore users so if you could tell me the file where users are kept and data.

First i try and fix it in the users data file or where ever it is w/e

if not i replace it.

Any ideas on what i can do?

Im using:
Windows XP
Xampp Beta - MySQL 5.0 - Apache 2.2.2 - With Perl Addon

Now im just stuck.

Thanks for the lovely xampp and i hope i get a fix soon!
Cheerz
Matthew.
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Re: MySQL Root - Max Quirers Per Hour - URGANT

Postby Tessi » 28. May 2006 20:26

Hi Neo,

Neo13 wrote:I accidently set for user account "root" max quieres 10 per hour. now soon as i load up sql it already reaches the max.


What about changing this back to its old value in the same way (well ...same accident)?

best regards,
Tessi
Ohne Werbung machen zu wollen, schaut mal hier rein: http://www.apachefriends.org/f/viewtopic.php?t=18155 . ich würde mich sehr über eine Antwort freuen.
Tessi
 
Posts: 16
Joined: 24. May 2006 12:52
Location: Berlin, Germany

Re: MySQL Root - Max Quirers Per Hour - URGANT

Postby Neo13 » 28. May 2006 21:00

Tessi wrote:Hi Neo,

Neo13 wrote:I accidently set for user account "root" max quieres 10 per hour. now soon as i load up sql it already reaches the max.


What about changing this back to its old value in the same way (well ...same accident)?

best regards,
Tessi


How? I dont know how because i locked myself out of phpmyadmin because it still says that the max quirers are reached.

Reboot and it loads abit and then locks again because its reached just by loading phpmyadmin.
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Postby Wiedmann » 28. May 2006 21:03

Simply use the mysql console client "mysql.exe".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Neo13 » 28. May 2006 23:23

Wiedmann wrote:Simply use the mysql console client "mysql.exe".


Do i have to run commands on that or will it just load up a panel?

Opened up says:

ERROR 1045 (28000): Access denied for user 'ODBC'@'localhost' (using password: NO)
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Postby Neo13 » 29. May 2006 11:32

Well any suggestions? I need a fix!
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Postby Naneau » 29. May 2006 12:33

Code: Select all
start >> execute >> cmd >> cd-to-xampp-dir >> cd mysql >> cd bin


type the following:

Code: Select all
mysql.exe -u root -p


Give your root password when it asks for it. You are now in the mysql console. You now want to select the database to use, which, in this case, is the mysql database.

Code: Select all
USE mysql


the information you want to change (max questions) is in the 'user' table. For root I would strongly advice a setting of '0', to avoid problems like this.

Code: Select all
UPDATE mysql SET `max_questions` = 0 WHERE `user` = 'root';


will do that for you. Good luck!

P.S. to exit the mysql command line tool type:

Code: Select all
exit
Naneau
 
Posts: 14
Joined: 18. May 2006 14:45

Postby Neo13 » 29. May 2006 16:04

EDIT: I done it but it didnt work

says that mysql.mysql dont exist

the tabe

when i put in:

Code: Select all
UPDATE mysql SET `max_questions` = 0 WHERE `user` = 'root';
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Postby Neo13 » 29. May 2006 17:43

worked thanks ur the best :D
Neo13
 
Posts: 6
Joined: 28. May 2006 17:25

Postby Naneau » 30. May 2006 13:11

no problem, using an sql command line tool can be a bit difficult if you've never done it before :)
Naneau
 
Posts: 14
Joined: 18. May 2006 14:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests