mysql keeps stopping!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mysql keeps stopping!

Postby tachu » 23. May 2006 22:55

Ok everything was working fine yesterday, but today the mysql service stopped automatically. I started it again on the control panel, but then it stops after like 3 seconds. it says something like port 3306 is taken or something...

First i thought it was the firewall, so i turned it off and it still doesnt work.

Any ideas why this is happening?
tachu
 
Posts: 11
Joined: 23. May 2006 22:46

Re: mysql keeps stopping!

Postby taustin » 24. May 2006 00:02

tachu wrote:Ok everything was working fine yesterday, but today the mysql service stopped automatically. I started it again on the control panel, but then it stops after like 3 seconds. it says something like port 3306 is taken or something...

First i thought it was the firewall, so i turned it off and it still doesnt work.

Any ideas why this is happening?


Be easier to guess if you had the exact error message.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby tachu » 24. May 2006 00:20

Ok, in the XAMPP Control Panel, I press the start button on MySQL, and it starts, but after about 3 seconds, it stops automatically. When installing, it said something like "MySQL service could not be installed because port 1336 is blocked." (that's not the exact port number, just from what I remember). Ok so then I tried running the mysql\mysql_installservice and it says "System eror 1067 has ocurred. The Process terminated unexpectedly."
tachu
 
Posts: 11
Joined: 23. May 2006 22:46

Postby tachu » 24. May 2006 00:26

Ok yea in phpMyAdmin it also tells me:
#1130 - Host 'localhost' is not allowed to connect to this MySQL server
tachu
 
Posts: 11
Joined: 23. May 2006 22:46

Postby taustin » 24. May 2006 00:27

Is there a port "taken" or "blocked"? They are different, and have different causes, and different solutions.

It isn't helpful to know that the error message is "like." What is the exact text of the error message?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby tachu » 24. May 2006 00:43

Forget it, I was able to fix it. I reinstalled the whole xampp again. Apparently there was an error in the pervious installation.

Thanks though.
tachu
 
Posts: 11
Joined: 23. May 2006 22:46

I too had the problem with XAMPP starting and stopping

Postby websensei » 15. September 2006 16:57

XAMPP's portcheck.exe utility showed a connection to an http server even though there was none.

I just deleted and reloaded all XAMPP files. Now it works.

Websensei
websensei
 
Posts: 1
Joined: 14. September 2006 20:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests