Need to download older versions of XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Need to download older versions of XAMPP

Postby fuzzyphil » 28. April 2006 18:55

Hi, is there a way I can download an older version of XAMPP as CreLoaded osCommerce version 2 is refusing to install.
Apparently this may have something to do with XAMPP's MYSQL version being to new.

Unless anybody knows what the answer to this creloaded installer error code is ??
1067 - Invalid default value for 'dt'

CREATE TABLE visual_verify_code ( oscsid varchar(32) NOT NULL, code varchar(6) NOT NULL, dt TIMESTAMP(12) NOT NULL DEFAULT 'CURDATE()', PRIMARY KEY (oscsid) ) TYPE=MyISAM;

Phil.
fuzzyphil
 
Posts: 6
Joined: 30. April 2005 12:53

Postby Wiedmann » 28. April 2006 19:24

You cannot set the default for a TIMESTAMP column to be the value of a function, like "'CURDATE()'". The DEFAULT value must be a constant like "CURRENT_TIMESTAMP".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby fuzzyphil » 29. April 2006 00:29

Wiedmann wrote:You cannot set the default for a TIMESTAMP column to be the value of a function, like "'CURDATE()'". The DEFAULT value must be a constant like "CURRENT_TIMESTAMP".


Are you saying substitute CURDATE() for CURRENT_TIMESTAMP ?

:?
fuzzyphil
 
Posts: 6
Joined: 30. April 2005 12:53

Postby MAGnUm » 02. May 2006 00:20

No thats not what he is saying constants are varables that dont change i.e. a constant value. you are trying, rather the script you are installing is trying to assign it a value via a function which is not possible for a default value in MYSQL. i would try removing that default value, and trying out the script to see if there are any ill effects. FYI as far back as MYSQL 4.1.9 or further this will not work, so a downgrade might not fix it. Later.
~~:M A G n U m:~~
(Disclaimer: if any of this info is confusing or vague tough, its free!!)
User avatar
MAGnUm
 
Posts: 151
Joined: 16. October 2003 18:08
Location: USA

Postby fuzzyphil » 02. May 2006 09:55

Thanks for the techie tips but I have now sorted the problem by installing an earlier version of XAMPP from here:
http://sourceforge.net/project/showfile ... e_id=89552

osCommerce isn't so much the problem as creloaded is - I presume some of the contributions may have been written to cater for an earlier version of mysql.

All sorted now.
Thanks.
fuzzyphil
 
Posts: 6
Joined: 30. April 2005 12:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests