Prgram error in phpMyAdmin???

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Prgram error in phpMyAdmin???

Postby DeVrije » 26. April 2006 19:55

In last January I installed XAMPP for Windows Version 1.5.1 (with PHP 5.1.1) and it does still work fine. Some weeks ago I created my passwords for mySQL and phpMyAdmin. And they do work properly. In the XAMMP welcome page I am able to use every hyperlink in the navigator but EXCEPT phpMyAdmin.

After clicking the hyperlink 'phpMyAdmin' I have to wait about 10 seconds for the following pop-up window 'Apache HTTP Server' with the following text 'In Apache HTTP Server an error is occurred and has to be closed. Sorry for this inconvenience'. When I pressed the button 'To NOT send', I got the following page:
===============================================

Warning: ini_set() [function.ini-set]: A session is active. You cannot change the session module's ini settings at this time. in C:\Program Files\xampp\phpMyAdmin\libraries\session.inc.php on line 46

Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\xampp\phpMyAdmin\libraries\session.inc.php:46) in C:\Program Files\xampp\phpMyAdmin\libraries\auth\cookie.auth.lib.php on line 110

Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\xampp\phpMyAdmin\libraries\session.inc.php:46) in C:\Program Files\xampp\phpMyAdmin\libraries\select_theme.lib.php on line 92

Welkom op phpMyAdmin 2.7.0-pl1

Language: ..........

Inloggen
(Cookies moeten aan staan voorbij dit punt.)
Gebruikers naam: .........
Wachtwoord: .........

===============================================

Do anybody know where I have done wrong? Or where I have to forget to initialize what? I have NOT modify any standard XAMPP file!
DeVrije
 
Posts: 23
Joined: 26. April 2006 19:34

Postby WorldDrknss » 28. April 2006 08:11

go to your phpmyadmin folder and open config.inc.php and change

Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'cookie';

to
Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'http';


and save restart apache and give it another try.
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby DeVrije » 30. April 2006 13:40

Unfortunately it does not help, and it should be worser, because I got the message 'Could not find the server or DNS-error'.

More information of the Apache HTTP Server error are as follows:
- AppName: apache.exe
- AppVer: 2.2.0.0
- ModName: php5ts.dll
- ModVer: 5.1.1.1
- Offset: 00097b26

What tot do now?
DeVrije
 
Posts: 23
Joined: 26. April 2006 19:34

Postby Dave_L » 01. May 2006 01:10

I don't know if this will help, but you could try upgrading phpMyAdmin to the latest stable version, 2.8.0.3.

The 2.7.x version seemed buggy to me.
User avatar
Dave_L
 
Posts: 212
Joined: 23. October 2004 00:43

Postby DeVrije » 01. May 2006 07:20

I shall try to de-install my xampp and to re-install your newest xampp version in May/June. I shall let you know teh status thereafter. Thank you very much for your attention to my phpMyAdmin problem!
DeVrije
 
Posts: 23
Joined: 26. April 2006 19:34


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests