PHP Cli not found

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP Cli not found

Postby McKenzie » 21. April 2006 19:41

Hi,

I am a new user of PHP. After downloading xampp-win32-1.5.1.exe and extracting it, I launched setup_xampp.bat.
I got the following error message "Sorry...cannot find php cli ! Must abort this process!".

This error message is not listed in the FAQ. So I need your help to know what I have done wrong...

Thanks in advance :wink:
McKenzie
 
Posts: 1
Joined: 21. April 2006 19:33

Problem with the setup_xampp.bat.

Postby cjlio1 » 03. May 2006 07:33

Do the following check if no one out there has told you already

1. make sure that all your files and the folders that you have extracted is located in your root directory i.e. c:\

as the following code from the *.bat file indicates

----------------------------------------------------
@ECHO OFF

if "%1" == "sfx" (
cd xampplite
)
if exist php\php.exe GOTO Normal
if not exist php\php.exe GOTO Abort

:Abort
echo Sorry ... cannot find php cli!
echo Must abort these process!
pause
GOTO END

:Normal
set PHP_BIN=php\php.exe
set CONFIG_PHP=install\install.php
%PHP_BIN% -n -d output_buffering=0 %CONFIG_PHP%
GOTO END

:END
pause
------------------------------------------------------

that if the current folder is not the xampplite folder it will try and do a change directory to the xampplite folder.
but the code just checks for any folders at the root and if you have the whole folder in another folder other then the root it will always prompt the abort message
cjlio1
 
Posts: 1
Joined: 03. May 2006 06:55


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests