change to another port

Problems with the Windows version of XAMPP, questions, comments, and anything related.

change to another port

Postby evy » 14. April 2006 16:04

is there anyway of changin the default port from 80 to sumthing else as my port 80 is blocked .. i dont use a router if that makes a difference .. and which file/s i have to edit to do this? .. nd how do i configure XAMPP allways accept "outside" connections. which file is this stored in ? thanks
evy
 
Posts: 7
Joined: 12. April 2006 16:09

Postby professionalgeek » 14. April 2006 16:58

You actually have to change two ports. First edit the apache\conf\httpd.conf file and find the line that looks like this:

Listen 80

Change the 80 to whatever port you want (just make sure it is not already used). Next edit the apache\conf\extra\httpd-ssl.conf and find the line that looks like this:

Listen 443

Change the 80 to whatever port you want and is available. Now restart apache.

Now to access IIS, just open HTTP://localhost and to access Apache, just open HTTP://localhost:portnumber (where portnumber is whatever you put in the httpd.conf file).

The second port (443) is for https (SSL) traffic. IIS grabs both ports (80 and 443) so you have to change Apache to use different ones. I hope this helps. Good look.

Mike
professionalgeek
 
Posts: 5
Joined: 14. April 2006 16:42
Location: Detroit, MI, USA

Postby evy » 14. April 2006 21:58

and that will allow outside connections ? also in status SSL and SSI are now sayin deactivated? sorry if i'm sounded a n00b ..i am :) thanks for any help
evy
 
Posts: 7
Joined: 12. April 2006 16:09

Postby professionalgeek » 17. April 2006 03:39

This is nothing in XAMPP that would "block" ports. What would be blocking incoming traffic would be a firewall (like Window's Firewall). Assuming that is the problem program, go to your control panel and select "Windows Firewall". Then click the "Exceptions" tab. Then click "add Port..." button. Give it a name (like web traffic), and enter the port you want to unblock (80). That will stop Window's Firewall from blocking that port. If you have the firewall turned off, then there is another firewall/router somewhere that is blocking that traffic.
professionalgeek
 
Posts: 5
Joined: 14. April 2006 16:42
Location: Detroit, MI, USA

Postby gleka » 21. September 2006 00:22

professionalgeek wrote:You actually have to change two ports. First edit the apache\conf\httpd.conf file and find the line that looks like this:

Listen 80

Change the 80 to whatever port you want (just make sure it is not already used). Next edit the apache\conf\extra\httpd-ssl.conf and find the line that looks like this:

Listen 443

Change the 80 to whatever port you want and is available. Now restart apache.

Now to access IIS, just open HTTP://localhost and to access Apache, just open HTTP://localhost:portnumber (where portnumber is whatever you put in the httpd.conf file).

The second port (443) is for https (SSL) traffic. IIS grabs both ports (80 and 443) so you have to change Apache to use different ones. I hope this helps. Good look.

Mike


I'm in the same position, but aol is my equivalent of IIS here. I wish to keep aol on port 443, so will edit apache. However, when i try to edit the apache\conf\httpd.conf file, windows cannot recognise the file. When i check the web, it still does not recognise the .conf extension. What program do i need to associate .conf files to, to allow me to edit said files.
gleka
 
Posts: 3
Joined: 20. September 2006 23:33
Location: England

Postby Izzy » 21. September 2006 00:27

Associate .conf with your favourite text editor or use drag and drop to your text editor then click on Save as file.conf from the File menu in your text editor.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests