Windows 98...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Windows 98...

Postby chiefbutz » 25. March 2006 20:30

Alright I am trying to install XAMPP on a Windows 98SE laptop, for testing purposes. I can't remember the exact error, but Apache can't start it has ot do with the line in the http.conf file where you specify the port it uses. It says it can't attach, or something or other like that. Can anyone help?
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20

Postby Wiedmann » 25. March 2006 21:55

Without an exact error message? No.

(Guessing don't help anybody...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chiefbutz » 25. March 2006 23:08

Valid point *grabs laptop and sets it up in front of main computer*

Ok the error says this:
[Sat Mar 25 17:17:57 2006] [crit] (OS 10106)Unrecognized Win32 error code 10106: alloc_listener: failed to get a socket for (null)
Syntax error on line 53 of C:/xampplite/apache/conf/httpd.conf
Listen setup failed


Line 53 of httpd.conf says
Code: Select all
Listen 80
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20

Postby Wiedmann » 25. March 2006 23:30

This laptop have a network connection?
You have installed the Winsock2 Update for Win98?

IMHO you have a problem with the TCP/IP driver for the networkcard. Try to reinstall the network drivers.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chiefbutz » 26. March 2006 12:42

No it is not connected to a network. It does have a dial up modem, but it is not used. The Win sock 2 Update is only needed for Windows 95 according to everything I have seen. Including Microsoft's website.
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20

Postby Wiedmann » 26. March 2006 13:02

No it is not connected to a network

That's a problem. You need a working network interface and valid ip for this interface if you want to start a server.

You should install the virtual loopback interface.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chiefbutz » 26. March 2006 13:04

And I get that where?
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20

Postby Wiedmann » 26. March 2006 13:10

It's part of your Windows:
IMHO:
Network properties --> Add network interface --> vendor Microsoft ...

Sorry, I have no Windows 98 at the moment.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chiefbutz » 26. March 2006 13:15

So you mean like this, except i do it in Windows 98?

Nope doesn't work. The only drivers show when I go there are the following:

Dial-Up Adapter
Microsoft PPP over ATM Adapter
Microsoft Virtual Private Networking Adapter
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20

Postby Wiedmann » 26. March 2006 13:26

The loopback adapter is available for every Windows. Please look in your system documentation or ask microsoft (eg. knowledge base or newsgroup) to find it.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chiefbutz » 26. March 2006 14:27

Alright, and that should do it? That will make it work. Thank you! Vielen Danke!
chiefbutz
 
Posts: 6
Joined: 25. March 2006 20:20


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests