Page 1 of 1

Windows Server 2003 R2 + XAMPP

PostPosted: 23. March 2006 05:24
by SpiderXarc
I didn't find this information here (easily at least), so I thought I would post what I did to make XAMPP run fully on w2k3r2, namely mysql as a service.

When you look at the mysql service created by the xampp control software, the path to the my.cnf file is relative (or at least not complete), and that is where the service registration fails. You have to specify the full, absolute path to that file for it to properly see it on service start up. You can do this manaully by typing the following (make sure the mysql service box is unchecked in the xampp control software).

from "Run..." type the following:

<full path to xampp root dir>\mysql\bin\mysqld-nt --install mysql --defaults-file="<full path to xampp root dir>\mysql\bin\my.cnf"

As an example -- my xampp folder is placed in d:\ so the root dir is d:\xampp and I typed the following:

d:\xampp\mysql\bin\mysqld-nt --install mysql --defaults-file="d:\xampp\mysql\bin\my.cnf"

Once you have done this mysql will autostart as a service, and it will appear checked in the xampp control panel. IMPORTANT -- Do not uncheck and recheck the service box in the xampp control software or you will re-apply the flawed service statement from the default installation. If you do, just repeat the steps in this post.

Best of luck to all you fellow XAMPPers. :wink:


PostPosted: 23. March 2006 10:14
by WorldDrknss
thanks for the info, Ill add it to