mysql: connot connect to the server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mysql: connot connect to the server

Postby John Betts » 19. March 2006 22:23

Everything was working perfectly, but now when I try to run mysql it links through to the internet and returns an error 2003 with the message "can't connect to mysql server on localhost (10061)"

Any help wiil be greatly appreciated.

John :(
John Betts
Bristol
England
e-mail: john.betts@virgin.net
John Betts
 
Posts: 5
Joined: 02. December 2003 17:25
Location: Bristol UK

Postby cj_nza » 20. March 2006 10:22

Everything was working perfectly, but now

Could you please elaborate on this statement - eg when was what running perfectly and what has changed from then to now.

it links through to the internet
The error message suggest that is is trying to connect to "localhost"

In any event you might be able to check the following (don't know what you changed from the original package):
1)Confirm that you MySQL Server is actually running. (Check status trough the XAMPP control panel or use the port check utility with the XAMPP distribution to see if port 3306 is been occupied by MySQL.
2) Confirm that the port number your MySQL sever listens on and the post number the client that wants to connect is actually the same eg 3306, 3307 or 3308.
cj_nza
 
Posts: 53
Joined: 06. September 2005 11:49

Postby John Betts » 20. March 2006 22:29

Mysql was running under windows ME. I changed the operating system to windows XP professional and had to reinstall the xampp suite. Since that time I have not managed to get mysql to run properly and I do not think that localhost is working correctly.

From the xampp control panel apache will run and so will mysql but if you want to use mysql it needs to connect to the internet. On allowing this to happen mysql is switched off.

It should use port 3306 but it would appear that this port might be blocked. Changing the port to 3307 or something similar makes no difference.

Any ideas will be very welcomed.

John
John Betts
Bristol
England
e-mail: john.betts@virgin.net
John Betts
 
Posts: 5
Joined: 02. December 2003 17:25
Location: Bristol UK

Postby cj_nza » 23. March 2006 04:33

Lets do one at a time:

From the xampp control panel apache will run and so will mysql but if you want to use mysql it needs to connect to the internet. On allowing this to happen mysql is switched off.
MySQL does not need to connect to "the internet" in order to be used - what exactly do you do that allows MySQL to connect (and die).

It should use port 3306 but it would appear that this port might be blocked.
Are you using Windows firewall and do you have MySQL and port 3306 listed as exceptions? (Or other firewall - open port 3306)

If not blocked by a firewall could you please indicate what process is blocking it.
cj_nza
 
Posts: 53
Joined: 06. September 2005 11:49

Re: mysql: connot connect to the server

Postby John Betts » 24. March 2006 21:28

John Betts wrote:Everything was working perfectly, but now when I try to run mysql it links through to the internet and returns an error 2003 with the message "can't connect to mysql server on localhost (10061)"

Any help wiil be greatly appreciated.

John :(


Thanks for the response so far. The situation is as follows:-

When I open up the Xampp control panel Apache is running but mysql is not.

I click on the start button for mysql and it begins to run. It then wants to connect to the internet. The specific program is:- mysql-nt.exe. When the connection is made mysql is switched off.

I know that mysql does not need to connect to the internet in order to run, why it attempts to do so is the problem. Can I stop this, and if so, will mysql run successfully ?

Thanks in anticipation

John
John Betts
Bristol
England
e-mail: john.betts@virgin.net
John Betts
 
Posts: 5
Joined: 02. December 2003 17:25
Location: Bristol UK

Postby cj_nza » 24. March 2006 23:54

John,

what you are describing sounds like MySQL cannot find an open port to listen at.

My other questions were for instance have you got a firewall running, if so is port 3306 open for MySQL to use?

If port 3306 is open or you do not have a firewall, could you determine what is using port 3306 (by using the port check utility for instance).
cj_nza
 
Posts: 53
Joined: 06. September 2005 11:49

Postby John Betts » 25. March 2006 18:26

Hi, Switching off the firewall does not make any difference. Can you suggest a good port check utility ?

Thanks once again

John
John Betts
Bristol
England
e-mail: john.betts@virgin.net
John Betts
 
Posts: 5
Joined: 02. December 2003 17:25
Location: Bristol UK

Postby cj_nza » 25. March 2006 22:48

As eluded to in my message of 20 March, XAMPP is ditributed with a port check utility that checks all the necessary ports used by its components and indicate the executable that is occupying that port. It is called "xampp-portcheck.exe" and you should have it inless you are running a very old version of XAMPP.
cj_nza
 
Posts: 53
Joined: 06. September 2005 11:49

Postby John Betts » 02. April 2006 19:07

Sorry for the late reply: I've been busy. Running the port checker reveals no problems. Downloading mysql from the mysql site and trying to run it independently from xampp makes no difference I still get the same error.

John
John Betts
Bristol
England
e-mail: john.betts@virgin.net
John Betts
 
Posts: 5
Joined: 02. December 2003 17:25
Location: Bristol UK

Postby Kolle » 03. April 2006 01:42

I have the same problem. Never used a webserver before, and have tried to fint something useful to set up. Though xampp looked okay, but i am really starting to doubt on this program. Seems like it only make problems, and nobody know how to solve them. Any other webserver programs that works better?
Kolle
 
Posts: 12
Joined: 01. April 2006 02:46

Postby WorldDrknss » 03. April 2006 02:13

Norton tends to cause this problem, if you have norton completely disable it, if you dont have norton and the problem is still there uncheck "SVC" for mysql and try starting MySQL if MySQL runs then its a problem with the MySQL service and to fix this go to:
start --> run --> type "cmd" without quotes --> type "sc delete mysql" without quotes, then go back to XAMPP Control panel and check "SVC" for mysql to reinstall the service.
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Kolle » 03. April 2006 02:40

Ah, thanks man. It really helpt me alot. Trying to log into mySQL now, but i think i will manage to figure out that.
btw, the (module) svc is of, but MySql is still running. Dont know if it is supposed to be that way. But it seems to work, so i am satisfied with that. Thx again! Had to type cmd and delete it and install it a few times, then it start working.
Kolle
 
Posts: 12
Joined: 01. April 2006 02:46


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests