SSI problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

SSI problem

Postby darkjetx » 13. March 2006 20:01

i saw other topics where it was talking about my problem , but i couldnt apply the solution

I'm running version 1.5.1 on my win xp sp 2

when i go to status it tells me :

Server Side Includes (SSI) DEACTIVATED

It's the single one deactivated

i went to http://localhost/xampp/ssi.inc and it said OK

then i went to http://localhost/xampp/ssi.shtml and it said

<!--#if expr="1 = 0" --><!--#else --><!--#include virtual="ssi.inc"--><!--#endif -->

Whats wrong or what should i do to make it work ?

Danke shon !
darkjetx
 
Posts: 10
Joined: 13. March 2006 19:46

Postby Wiedmann » 13. March 2006 20:03

Just enable SSI in the "httpd.conf". That's all.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby darkjetx » 13. March 2006 20:45

is this what i have to edit?

Code: Select all
# To parse .shtml files for server-side includes (SSI):
    # (You will also need to add "Includes" to the "Options" directive.)
    #
    #AddType text/html .shtml
    #AddOutputFilter INCLUDES .shtml
</IfModule>


I dunno what i have to do :oops:

Maibe i need a free management panel or somethin` to do the hard work...if one exists
darkjetx
 
Posts: 10
Joined: 13. March 2006 19:46

Postby Wiedmann » 13. March 2006 20:59

Code: Select all
#AddType text/html .shtml
#AddOutputFilter INCLUDES .shtml

dunno what i have to do

Remove the two "#".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby darkjetx » 13. March 2006 21:07

thx a lot :)

now i'll sleep cozz it didnt go through my mind to remove those # :lol:

but b4 i'll install zpanel

thanks for the help again
darkjetx
 
Posts: 10
Joined: 13. March 2006 19:46

There's one more step, I think...

Postby ivi » 20. March 2006 01:47

As a comment in http.conf suggests, you might also need to:

- add "Includes" to a list of "Options" (after one other option)

Note: There may be a side-effect:

xampp's Status page shows false-negatives for SMTP & FTP
...even when they are Active.

Has anybody got a fix for these false-negatives (yet)...? ;-)

PS Thanks for the tip, near the top of this thread.
ivi
 
Posts: 5
Joined: 06. March 2006 10:53

Postby WorldDrknss » 23. March 2006 10:38

change

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

to

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests