What to do when your php scripts dont support smtp?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

What to do when your php scripts dont support smtp?

Postby WorldDrknss » 09. March 2006 11:36

What to do when your content management system or any other script only supports sending mail with php, but you need smtp with authentication well this is what you do.
Read Carefully!!!

open xampp\apache\bin\php.ini

Change this:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "C:/xampp/xampp/sendmail/sendmail.exe -t"

to this:
[mail function]
; For Win32 only.
;SMTP = localhost
;smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = "yourxampppath/sendmail/sendmail.exe -t"

then go to your sendmail folder and open sendmail.ini and make it look similar to this:

; configuration for fake sendmail

[sendmail]

; you must change mail.mydomain.com to your smtp server

smtp_server=localhost

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=local

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

;error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

;debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

auth_username=yourusername
auth_password=yourpassword
; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines

;pop3_server=
;pop3_username=
;pop3_password=

; to force the sender to always be the following email address, uncomment and
; populate with a valid email address. this will only affect the "MAIL FROM"
; command, it won't modify the "From: " header of the message content

;force_sender=me@localhost

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting. you can manually set the ehlo/helo name if required

;hostname=localhost

then your all done, and now you will never have to worry about changing your mail settings to smtp, or sendmail, you can now leave it as php :)
Good Luck

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby giupi » 02. August 2006 16:34

Hello,

my smtp requires now authentication (I used without problems XAMPP before they changed the smtp auth); I followed the instruction but it does not work...

I even restarted the computer to be sure about the configuration.

Do I have to put in sendmail.ini my smtp server or do I have to leave "localhost"? in this last case do I have to use mercury mail in conjuction with xampp?

Anyway in sendmail.ini I've put both localhost and my smtp server with username and passwd for authentication... but without success... still confused...

Thanks in advance for your help...

Giuseppe
giupi
 
Posts: 1
Joined: 02. August 2006 16:22

Postby ClarkF1 » 16. August 2006 16:30

I followed these instructions but I'm now unable to use Outlook to receive my ordinary email.

I'm using XAMPP on windows and only using it as a testing/development server.

I've undone all the changes. I rebooted and it's working again.

The email didn't get sent anyway.
ClarkF1
 
Posts: 1
Joined: 16. August 2006 16:23

Postby WorldDrknss » 17. August 2006 12:40

You will still need to use MercuryMail.
Remember that "sendmail is not a MTA"

Outgoing: Server -> Sendmail -> Mercury -> Client
Incoming: Client -> MTA -> Mercury -> Client
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests