HELP! PHP PROBLEM!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

HELP! PHP PROBLEM!

Postby Juanu » 08. March 2006 12:02

I'm getting the following error when I try to access my php files.

[Wed Mar 08 07:44:19 2006] [error] [client IP-Number] C:/Vermouth/web/cgi-bin/install.php is not executable; ensure interpreted scripts have "#!" first line
[Wed Mar 08 07:44:19 2006] [error] [client IP-Number] (9)Bad file descriptor: don't know how to spawn child process: C:/Vermouth/web/cgi-bin/install.php

Don't know how to fix it.

Any Ideas?
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56

Postby Juanu » 09. March 2006 22:19

Anyone?

I can't find this problem anywhere!

Please, HELP ME!

:cry:
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56

Postby WorldDrknss » 10. March 2006 01:04

you need to change all your cgi scripts to point to the correct perl file instead of the default #!/usr/bin/perl

examples

#!/Program%20Files/xampp/perl/bin/perl
#!/apachefriends/xampp/perl/bin/perl
#!/xampp/xampp/perl/bin/perl

you will need to add something similar to these as the first line in all your cgi scripts.

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Juanu » 11. March 2006 19:58

Ok
So I added the following line to my INSTALL.php

#!C:/Archivos%20de%20programa/xampp/perl/bin/perl

Thats where my xampp is installed.

But my web and php files are on c:\vermouth\web\cgi-bin\

Now i have another error

couldn't create child process: 720003: install.php

ANY CLUES??? HELP PLEASE!!
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56

Postby WorldDrknss » 12. March 2006 09:51

that error is caused when your script is looking for a folder or a file in your cgi-bin folder, check your error logs for the proper files its looking for.

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Wiedmann » 12. March 2006 11:50

So I added the following line to my INSTALL.php

#!C:/Archivos%20de%20programa/xampp/perl/bin/perl

A .php-File is not a Perlscript and so it doesn't need a shebang.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: HELP! PHP PROBLEM!

Postby Juanu » 12. March 2006 12:26

Wiedmann wrote:A .php-File is not a Perlscript and so it doesn't need a shebang.


SO... We are back to the main problem again....


Juanu wrote:I'm getting the following error when I try to access my php files.

[Wed Mar 08 07:44:19 2006] [error] [client IP-Number] C:/Vermouth/web/cgi-bin/install.php is not executable; ensure interpreted scripts have "#!" first line
[Wed Mar 08 07:44:19 2006] [error] [client IP-Number] (9)Bad file descriptor: don't know how to spawn child process: C:/Vermouth/web/cgi-bin/install.php

Don't know how to fix it.

Any Ideas?
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56

Postby Wiedmann » 12. March 2006 12:45

[Wed Mar 08 07:44:19 2006] [error] [client IP-Number] C:/Vermouth/web/cgi-bin/install.php is not executable; ensure interpreted scripts have "#!" first line

- What is this for a directory? Any settings for this directory in your "httpd.conf"
- Why want you execute a php-script via cgi?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Juanu » 12. March 2006 19:40

I want to install a PHP Guetsbook I downloaded.
Im not really an expert on this issue so i took the files and put them on the cgi-bin folder....

where should they go else?....
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56

Postby Juanu » 12. March 2006 19:45

....

I found the problem...

I droped all the files on another directpory and it worked just fine...

Thanx all for the help anyway!!
Juanu
 
Posts: 6
Joined: 08. March 2006 11:56


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests