Problems accessing non-local disks

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems accessing non-local disks

Postby OwenWatson » 08. March 2006 10:47

I have an install of the latest xampp/apache that decided to stop accessing web documents that were on the fileserver elsewhere on the network. Here's the vhost lines:
<VirtualHost 202.36.162.18:80>
ServerName test.rsnz.org
DocumentRoot W:/test
ServerAdmin webmaster@rsnz.org
ErrorLog logs/test.rsnz.org-error_log
CustomLog logs/test.rsnz.org-access_log common
</VirtualHost>
Whenever I try and access test.rsnz.org I get a 403, which goes away if I change documentroot to a local disk.
Changing DocumentRoot to the UNC path (//Fileserver/web/test) makes no difference.
apache is running as a console app under a domain admin account, so permissions shouldn't be a problem (indeed, accessing the paths above is no problem in Explorer).

Any clues on how to sort this out? The access log and error log give no extra clues.
OwenWatson
 
Posts: 8
Joined: 28. November 2005 04:29

Postby WorldDrknss » 08. March 2006 11:17

remove these two lines save and restart apache
ErrorLog logs/test.rsnz.org-error_log
CustomLog logs/test.rsnz.org-access_log common

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby OwenWatson » 08. March 2006 22:57

Did that: no difference.
OwenWatson
 
Posts: 8
Joined: 28. November 2005 04:29

Postby OwenWatson » 08. March 2006 23:17

Found it: I put this in http.conf:

<Directory "W:/test">
Options FollowSymLinks
Order deny,allow
Allow from all
</Directory>
OwenWatson
 
Posts: 8
Joined: 28. November 2005 04:29


Return to XAMPP for Windows

Who is online

Users browsing this forum: DarthSidus and 53 guests