MySQL have_openssl

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL have_openssl

Postby Noel » 07. March 2006 22:25

When I 'show variables' in MySQL, I see that have_openssl=NO. Was MySQL compiled with openssl? If so, then how do I activate / otherwise get MySQL working with ssl connections?

I've searched high and low, and there just isn't a lot of documentation on this feature.
http://dev.mysql.com/doc/refman/5.0/en/ ... enssl.html

Help much appreciated.
Noel
 
Posts: 3
Joined: 07. March 2006 22:16

Postby Wiedmann » 07. March 2006 22:58

Which XAMPP version?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Noel » 09. March 2006 03:36

The latest from the downloads section, xampp-win32-1.5.1-installer.exe.

ApacheFriends XAMPP (basic package) version 1.5.1

+ Apache 2.2.0
+ MySQL 5.0.18
+ PHP 5.1.1 + PHP 4.4.1-pl1 + PEAR
+ eAccelerator 0.9.4-rc1
+ PHP-Switch win32 1.0 (from Apachefriends, use the "php-switch.bat")
+ XAMPP Control Version 2.1 from www.nat32.com
+ XAMPP Security 1.0
+ SQLite 2.8.15
+ OpenSSL 0.9.8a
+ phpMyAdmin 2.7.0 pl1
+ ADOdb 4.68
+ FPDF 1.5.3
+ Mercury Mail Transport System v4.01b
+ FileZilla FTP Server 0.9.11
+ Webalizer 2.01-10
+ Zend Optimizer 2.6.0
Noel
 
Posts: 3
Joined: 07. March 2006 22:16

Postby Wiedmann » 09. March 2006 12:41

ApacheFriends XAMPP (basic package) version 1.5.1

As you can see in the "xampp-changes.txt", MySQL have ssl support.

When I 'show variables' in MySQL, I see that have_openssl=NO.

Than that is not from a XAMPP 1.5.1. The initial state in 1.5.1 is "have_openssl = DISABLED".

If you need ssl, just enable it in "my.cnf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Noel » 09. March 2006 15:04

Actually, I didn't notice it before, but I guess this build doesn't have ssl support for MySQL. Any ideas which builds/versions of xampp for windows have ssl support for MySQL?


From xampp-changes.txt:

08 Jan 2006, XAMPP 1.5.1
- UPDATE MySQL 5.0.18 (without ssl support)

mysql> show variables where variable_name='have_openssl';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_openssl | NO |
+---------------+-------+
1 row in set (0.00 sec)
Noel
 
Posts: 3
Joined: 07. March 2006 22:16

Postby Wiedmann » 09. March 2006 15:40

Interesting, the beta from 1.5.1 was with ssl...

You can try 1.5.0 or definitely it is in the latest beta (1.5.2-beta1).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby scranmer » 04. April 2006 18:05

Noel sorry to hijack this but I have a related problem.

In 1.5.1 PHP4 is compiled with SSL but PHP5 does not seem to be ?!?!? I have been trying to test a small script wich uses the command ftp_ssl_connect this works fine under PHP v4 but dies under v5.

Can anyone help?

TA

Si.
scranmer
 
Posts: 26
Joined: 20. May 2004 14:59
Location: UK, Southport


Return to XAMPP for Windows

Who is online

Users browsing this forum: DarthSidus and 51 guests