Apache won't install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't install

Postby DoctorBeaver » 03. March 2006 22:29

I've downloaded the full version of Xampp and when I try to install it I get a message that Apache service can't install as port 433 is blocked. I read the FAQ & disabled the Microsoft firewall as advised. What do I do?
DoctorBeaver
 
Posts: 4
Joined: 03. March 2006 22:23

Postby alucard01 » 04. March 2006 08:55

Stop IIS services and try to reinstall again.

Hope it helps.
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51

Postby DoctorBeaver » 04. March 2006 10:26

Does IIs come as standard with XP Home? I certainly haven't downloaded it. But if it is on my PC somewhere, how do I find out & disable it?
DoctorBeaver
 
Posts: 4
Joined: 03. March 2006 22:23

Postby alucard01 » 06. March 2006 07:50

Hi.

You can right click your "My Computer" icon > select manage > in a new pop-up window, at the left-panel, expand the branch and look for "services", once found and click, then search for something like "IIS", then disable them.

Most likly if you cannot install apache because of port problem, it is caused by port conflict. So disable the program which use the port will work.

Hope it helps.
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51

Postby DoctorBeaver » 06. March 2006 15:52

alucard - I don't have IIs on my PC.
To be honest, I've had so much hassle with this I'm just dumping the whole project. All I wanted to do was evaluate BB software on my PC before loading it to my website. I've posted on 3 or 4 forums about it & had various advice thrown at me. I've now tried 4 different servers (Xampp, Xitami, Abyss & JSAS - all of which I've been told are a doddle to get working), 2 versions of Apache, 2 versions of php, 2 versions of MySql, 4 different BB systems, & I'm getting nowhere with it. Nothing will talk to any of the other components. I did manage to get php working under JSAS (after quite a bit of farting around) but it refuses to recognise any MySQL stuff.
I've followed the installation procedures to the letter, read all the help files, done everything I'm supposed to - then done it all again in case I did something wrong - but it just won't have it. Some of the help docs have said I have to modify certain files - but the files it refers to don't exist anywhere on my PC. In the FAQ for 1 of the installations it advised me to disable my firewall (I've got a feeling that was in the Apache installation FAQ). WTF! I'm not disabling that for anyone - especially as I only want to run the BB software locally.
I've been working on this for the past 9 days & I'm now so sick of it I'm consigning the whole thing to the scrap heap. But thanks anyway for replying.
DoctorBeaver
 
Posts: 4
Joined: 03. March 2006 22:23

Postby alucard01 » 06. March 2006 16:32

well, I can understand your feeling.

Having a problem and with no idea on why it happen is very annoying...

Ok, back to the issue:

I wonder if it's your mistake or mine, are you sure you are looking at port 433 (Port I have no understanding)? not 443(SSL specific port)?

The reason why I told you to disable IIS is because if IIS start, it may use port 443.

Now, if you still insist that it is 433 but not 443, than go this way:

open command prompt in windows > type "netstat" without quote

it will show up which port is currently opened, or type "netstat /?" for detail switch.

What I want you to see is: find out which application use the port 433.

Apache said that port is blocked, which may be caused by:

- another application use that port also
- you haven't had "listen 433" in your httpd.conf file.
- you haven't configure your network card AND router(if any) to accept 433 traffic

And the final assort, go digging the errorlog of Apache and see what is appearing.

Hope it helps.
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51

Postby DoctorBeaver » 06. March 2006 18:21

OK, I've got netstat running, but there's no mention of 433. There's a lot of stuff relating to www.igetnet.com:xxxx where xxxx is a 4-digit number.
This particular PC isn't on a network, so it can't be that that's interfering.
I'm pretty sure it was 433 not 443 (you've got me wondering now).
httpd.conf is 1 of the files that was mentioned in the FAQ. I did a search for it & it was nowhere to be found.
I can't begin to tell you how frustrated I've got with it. I came close to chucking the PC out of the window yesterday. But then I thought, "hmmmm - £1500 worth of PC? Nah, I'll just ditch the project"
I'm not exactly a beginner where computers are concerned. I've got a BSc in computer science (that was many years ago), started working with computers in 1979, & I worked as a DB consultant in the late 80s. This is the 1st time I've not been able to crack a problem.
DoctorBeaver
 
Posts: 4
Joined: 03. March 2006 22:23


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests