Apache can't be started

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache can't be started

Postby david_hoepelman » 27. February 2006 08:20

Hello,
yesterday suddenly my localhost gave on every page a blank screen, after going trough the processes and control panel, i saw that the apache service coudn't be started.
I decided to uninstall my old xampp 1.4.7 and install 1.5.1, but this time the service couldn't be started too! I don't know what to do, could you please help me?
another tyhing, when you try to start the service from the "services" configuration (in control panel) , it says: "Couldn't start service Apache2, if this isn't a microsoft service, you should contact the manifacturer and specify errorcode 1"
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands

Postby WorldDrknss » 27. February 2006 08:36

go to start run type cmd.exe
then type
sc delete Apache2
then reinstall the service with "apache_installservice.bat" in "\xampp\apache".

http://xampptutorials.com
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby david_hoepelman » 27. February 2006 09:04

Nope, error:
testing httpd.conf
Errors reported here must be fixed before service can be started
(OS 10048) Every socketaddress (protocol/network adress/port) can normally only be used once . : make_sock: could not bind to adress 0.0.0.0:80 no listening port available, shutting down
unable to open logs
Now we start Apache2 :)
Coudn't be started blablalbla etc etc etc

specific error: 1
typ NET HELPMSG 3547 for more help
Press any key to continue...

(sorry if the grammar is a bit bad, I translated the dutch messages to english)
NET HELPMSG 3547 doesn't provide much information too, is says "Reference the manifacturers manual for more information"

Also, my mysql service can't be started too! :( Is there any way to acces one table in a database while the service is down?
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands

Postby Wiedmann » 27. February 2006 11:45

(OS 10048) Every socketaddress (protocol/network adress/port) can normally only be used once . : make_sock: could not bind to adress 0.0.0.0:80 no listening port available, shutting down

There is allready another webserver running on your system. Try "xampp-portcheck.exe".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby david_hoepelman » 27. February 2006 12:55

After a DEP warning an a crash, It says that skyp0e is using port 80, will try disabling it.

It works!! thank you

(i'm using skype 2 btw, maybe a bug in it or something?)
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands

Postby david_hoepelman » 27. February 2006 12:57

only now the mysql service or just starting doesn't work, no error at installservice.bat or something...
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands

Postby Wiedmann » 27. February 2006 13:04

It says that skyp0e is using port 80,

Right. You can disable this behaviour in the Skype settings --> Skype manual

only now the mysql service or just starting doesn't work, no error at installservice.bat or something...

Windows logs?

BTW:
You can start MySQL with "mysql_start.bat"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby david_hoepelman » 27. February 2006 13:18

no, can't start it too with mysql_start.bat, this is the error that it gives:
Can't find messagefile in C:\Program Files\C:\Program Files\xampp\mysql\share\english\errmsg.sys
The C:\Program Files\ twice isn't a typo or something, it is what it says.
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands

Postby Wiedmann » 27. February 2006 13:39

Are the paths correct in "\xampp\mysql\bin\my.cnf"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby david_hoepelman » 27. February 2006 15:54

No, that was the problem, everywhere stood C:/Program FilesC:/Program Files, I edited it and it seems to work! Thank you!
david_hoepelman
 
Posts: 8
Joined: 03. September 2004 19:47
Location: Netherlands


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests