problem accessing server from LAN

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problem accessing server from LAN

Postby belgacia » 26. February 2006 15:34

My situation is pretty weird, accessing from any PCs on LAN other than the local machine can only ‘view’ the text part of a page. No Gif images can be open. However browser on the localhost has no problem.

My server is running Windows XP with latest XAMPP installed.
I have checked the Windows built-in firewall, ICF is not enabled.

Please kindly advise.
belgacia
 
Posts: 2
Joined: 26. February 2006 14:55

Postby alucard01 » 27. February 2006 09:19

I have also encounter such issue but solve:

1. Using other's computer to browser the text-only page.
2. right click the page, and LOOK AT THE SOURCE HTML CODE.
3. Watch out the part that show the image. The important point is, what is the path of this image?

90% of this problem is caused by incorrect path, which is caused by incorrect setting of your website.

For example, when I use Mambo (It's joomla now), and have other people access my website, they can only see the text but no image. After digging into the issue I found that in Mambo there is a variable :

$MOS_live_site = "http://localhost/mambo"

This variable make all path, including images, to:

http://localhost/mambo/images/myImage.gif

Which, in my case, is of course not the right path.

So I reconfig this variable to :
"http://".$_SERVER['HTTP_HOST']."/mambo"

Then problem solved.

So the important thing is: look at the source HTML code and see what is the path of your images are being pointed to.

Hope it helps.
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51

Postby belgacia » 27. February 2006 17:37

Many thanks to alucard01.

You're right!!

All gif links point to localhost, so what settings should I change? Apache or MySQL?
belgacia
 
Posts: 2
Joined: 26. February 2006 14:55

Postby alucard01 » 01. March 2006 09:23

It depends.

Just see what web application do you use.

Like what my previous post said before, go digging your GIF link, read the source code and find out which variable(s) control the path information. Then change that part.

Hope it helps.
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests