Advanced Users:

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Advanced Users:

Postby WorldDrknss » 25. February 2006 02:09

Source provided by:

Setting up VirtualHost with .ASP, .PL, .CGI and with SSI, custome error logs and with .htaccess

Make sure you have Perl installed:
Open httpd.conf and remove "#" from AddType and AddOutputFilter on line 436-437
Open httpd.conf line 223 change AllowOverride None to AllowOverride All
Open httpd-xampp.conf fine AddType ("line 9") and add .shtml to the end of that.
Open httpd-vhosts.conf and create vhost similar to; change to your needs.:


<VirtualHost *:80>
DocumentRoot /srv/www/thegamerslounge
<Directory "/srv/www/thegamerslounge">
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
<Directory "/srv/www/thegamerslounge">
Options Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddHandler server-parsed .html .htm .shtml .shtm
HostnameLookups Off
ErrorLog /srv/www/thegamerslounge/logs/error_log
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
CustomLog /srv/www/thegamerslounge/logs/access_log combined
ServerSignature On
ScriptAlias /cgi-bin/ "/srv/www/thegamerslounge/cgi-bin/"
<Directory "/srv/www/thegamerslounge/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
DirectoryIndex index.html
ErrorDocument 400
ErrorDocument 403
ErrorDocument 404
AccessFileName .htaccess
AddHandler cgi-script .cgi
Alias /error/ "/srv/www/thegamerslounge/error/"
<Directory "/srv/www/thegamerslounge/error">
AllowOverride None
Options IncludesNoExec
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority en
User avatar
Posts: 292
Joined: 17. September 2005 13:40

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests