Instability problems with XAMPP and XPhome sp1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Instability problems with XAMPP and XPhome sp1

Postby Peteruittilburg » 18. February 2006 22:04

Hello,

First my apologize for using English. My (writing in) German is not that that good, so I am writing in English. Reading German is mutch better. I have some terrible problems running XAMPP on my PC with XPhome sp1, and it is starting to look hopeless. I want to run osCommerce on XAMPP

First I installed “xampp-win32-1.5.1-installer.exe”
Installing went well, but it is running instable. Clicking on the XAMPP shows me that every is running without a problem. Opening http://localhost/xampp/ sometimes doesn’t open, and if it does, clicking on “status” is not working. After some time “page can’t be found” appears. En even when it does appears, some of the service are indicated as not running. Trying it again will show them working, but an other one won’t, and so on….
With every test I have to restart my computer because shutting down is also not working properly.
It is not stable.

I also have the CPU 99% load problem.
FAQ of the apachefriends sites gives a solution.
Please, enable following line = > # Win32DisableAcceptEx in the /xampp/Apache/conf/httpd.conf.
But in this line is not present in httpd.conf (20kB big)
There is a file named oldhttpd.conf (40kB big) containing that line ?!?

I gave it up.
Someone advised me to use: “xampp-win32-1.4.4-installer.exe”.
I did, and it is running, with some problems.
Xampp_start and xampp_stop won’t work properly.
What will work is starting with clicking 2 files:
Apache_start.bat
Mysql_start.bat

Stopping must be done via:
Apache_stop.bat
Mysql_stop.bat

This is really not user friendly.
Who has some advice about what to do?
I really don’t know what to do anymore…

Best regard,
Peter
Peteruittilburg
 
Posts: 3
Joined: 18. February 2006 21:30

Postby CPcoder » 23. February 2006 04:16

Peter, I wonder if you have solved your problem?

I have CPU issue also. Except I got this advice to uncomment " Win32DisableAcceptEx" httpd-mpm.conf, not httpd.conf.

I looked in httpd.conf and saw I also needed to uncomment a line so that the above file will get read:
Code: Select all
# Server-pool management (MPM specific)
 Include conf/extra/httpd-mpm.conf


It did not help me. Before that, I tried editing httpd.conf as it said in the FAQ you found, which didn't help, either. I still have the CPU-usage issue, either way.

I am wondering if you have solved this problem another way?
WinXP Home SP2
XAMPP 1.5.1 in top-level directory
Unzipped directly from .zip file
no other severs running
CPcoder
 
Posts: 30
Joined: 16. February 2006 08:44

Postby Peteruittilburg » 24. February 2006 16:13

CPcoder wrote:Peter, I wonder if you have solved your problem?


No I am sorry. Problem is not solved, and nobody seems to be able to help me :(

CPcoder wrote:I am wondering if you have solved this problem another way?

Now I am using an older version, version 1.4.4, and this version is working whithout any problem.

Hope you can do something with this info...
Peteruittilburg
 
Posts: 3
Joined: 18. February 2006 21:30

Postby CPcoder » 25. February 2006 02:19

Thanks. If no one can figure it out, I may try 1.4.4. :? This is my first time using XAMPP.
WinXP Home SP2
XAMPP 1.5.1 in top-level directory
Unzipped directly from .zip file
no other severs running
CPcoder
 
Posts: 30
Joined: 16. February 2006 08:44

Postby Peteruittilburg » 25. February 2006 14:27

CPcoder wrote:Thanks. If no one can figure it out, I may try 1.4.4. :? This is my first time using XAMPP.

I am ( almost) onvinced that version 1.4.4 will work for you. On this very moment, I advised 2 other people having the same problem with XAMPP in combination with osCommerce. It is working for the both of them.

Good luck!
Peteruittilburg
 
Posts: 3
Joined: 18. February 2006 21:30

Postby CPcoder » 15. March 2006 05:48

Thanks, Peter.

I cannot get Perl to work on XAMPP 1.5.1, either, not at all. I'm going to try 1.4.4 and see what happens.
WinXP Home SP2
XAMPP 1.5.1 in top-level directory
Unzipped directly from .zip file
no other severs running
CPcoder
 
Posts: 30
Joined: 16. February 2006 08:44


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests