Q: Guide posted by WorldDrknss

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Q: Guide posted by WorldDrknss

Postby Cifly » 14. February 2006 20:45

Followed this great guide, posted by WorldDrknss, to start my own webserver and set security etc. in XAMPP.

The guide explains, that i should scrool down and delete everything in the C:\xampp\xampp\apache\conf starting at #NameVirtualHost *:80.

But i met a problem: nothing in my file reflects these lines - these data is not in my file.

What do i do then, when i want to make these changes, which WorldDrknss mention in the guide :?:

Please - let me here from you :)

Kind regards
Cifly
Cifly
 
Posts: 4
Joined: 14. February 2006 19:38

Postby WorldDrknss » 15. February 2006 02:12

if your using the new version 1.5.1+ then you will need to follow the new tutorials at http://xampptutorials.com. The best tutorials for you will most likely be the flash tutorials so that you would be to configure xampp while following the videos.

:)
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Cifly » 15. February 2006 11:55

Yes - i use ver. 1.5.1

Followed the flash guide.

But after i set the password for MySQL and .htaccess, i am no longer allowed to load phpMyAdmin. That is, that when i enter phpMyAdmin a popup asks for the Username and Password. I figure that these informations are the ones that i entered when setting username and password for .htaccess.

But the system returns and informs that the username and/or password ain't correct.

Otherwise, a very fine flash guide - a good idea for newbies and dummies like me :)

What did i do wrong?
Cifly
 
Posts: 4
Joined: 14. February 2006 19:38

Postby killerB » 15. February 2006 12:04

unless you changed it the username is 'root' ...try 'root' as the username
killerB
 
Posts: 8
Joined: 15. February 2006 11:58

Postby Cifly » 15. February 2006 12:28

Great, it worked :D

But i don't understand why, because when i registered new security settings, i wrote a new username as well as a new password.

And now, when i Log Off, it asks me ones again for these informations, and now it won't let me log off, saying my username and/or password is invalid.

Furthermore
I followed the guide to set up VirtualHosts.

I must be an idiot, because this i can't get to work either.

Here is what i've done:

    1) Changed the permission attribute in the httpd.conf file

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all
    </Directory>

    2) Entered this information into the file httpd-vhosts.conf

    NameVirtualHost *:80

    <VirtualHost *:80>
    DocumentRoot C:/www/flygenrings
    ServerName flygenrings.dk
    ServerAlias www.flygenrings.dk
    </VirtualHost>

    3) Dubbleclick on my index.php ind my www/flygenrings folder.

    But it does not run the php code as expected.

What am i doing wrong :?:
Cifly
 
Posts: 4
Joined: 14. February 2006 19:38

Postby killerB » 15. February 2006 12:47

never had the logging of problem so can't help, the username password you are changing is to make xampp safe not the mysql database by default the username is set to 'root'.

The only way to change the root password is shown on the Xampp site under the FAQ's http://www.apachefriends.org/en/faq-xam ... #password0

Try deleting your cookies but next time when you set a username and password for Xampp highlight the HTTP button not the Cookie before pressing submit

3) Dubbleclick on my index.php ind my www/flygenrings folder.

But it does not run the php code as expected.



i'm a newbie like you so take this with a pinch of salt..i don't thing you can run php code by double clicking, you have to run it in your web browser

try typing 'localhost/flygenrings/' in the address bar...example if you what to run test1.php in your flygenrings folder type localhost/flygenrings/test1.php this is asuming you are offline
killerB
 
Posts: 8
Joined: 15. February 2006 11:58

Postby Cifly » 15. February 2006 13:41

try typing 'localhost/flygenrings/' in the address bar...example if you what to run test1.php in your flygenrings folder type localhost/flygenrings/test1.php this is asuming you are offline


Nope, didn't do the trick :?

Tried with:

- localhost/www/flygenrings/index.php

- http:://localhost/www/flygenrings/index.php (last : is to remove link)

- http:://localhost/flygenrings/index.php (last : is to remove link)

Thx for suggestion it though.[/list]
Cifly
 
Posts: 4
Joined: 14. February 2006 19:38

Postby SeanO » 15. February 2006 15:30

http:://localhost/index.php will work for you. You did set the documentroot to be flygenrings after all.
Last edited by SeanO on 15. February 2006 15:38, edited 1 time in total.
SeanO
 
Posts: 17
Joined: 31. January 2006 21:00

Postby killerB » 15. February 2006 15:31

have you added this line '127.0.0.1 flygenrings' to your host file found in windows/system32/drivers/etc ?....0r is it www.flygenrings ...no clue what so ever what i'm talking about :lol:

BTW http://www.flygenrings.dk/ is online i can see it :D
killerB
 
Posts: 8
Joined: 15. February 2006 11:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests