eaccelerator configs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

eaccelerator configs

Postby Killerfrog » 05. February 2006 19:40

Hi!

Here is my eaccelerator config (I've updated my server to the last version doing the clean install to pass from 1.5.0 to 1.5.1), but it seems eaccelerator don't produce tmp file anymore and I don't know why :

Code: Select all
[eAccelerator]
;extension=eaccelerator.dll
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "C:\apachefriends\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "1"
;eaccelerator.debug = "0"
eaccelerator.check_mtime = "1"
;eaccelerator.filter = ""
;eaccelerator.shm_max = "0"
;eaccelerator.shm_ttl = "0"
;eaccelerator.shm_prune_period = "0"
;eaccelerator.shm_only = "0"
;eaccelerator.compress = "1"
;eaccelerator.compress_level = "9"
;eaccelerator.keys = "shm_and_disk"
;eaccelerator.sessions = "shm_and_disk"
;eaccelerator.content = "shm_and_disk"
;eaccelerator.admin.name =
;eaccelerator.admin.password =


Could someone tell me how to configure eaccelerator ??

On version 1.5.0 code was :

Code: Select all
[eAccelerator]
extension=eaccelerator.dll
;zend_extension_ts="c:\apachefriends\xampp\php\eaccelerator.dll"
;zend_extension="c:\apachefriends\xampp\php\eaccelerator.dll"
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "c:\apachefriends\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "1"
;eaccelerator.check_mtime = "1"


Thx a lot in advance
Killerfrog
 
Posts: 75
Joined: 18. December 2004 21:16

Postby christh21 » 05. February 2006 23:45

At least in the Linux version there isn't an eAccelerator compiled for PHP 5.1.1, so to use it you'll need to switch to PHP4.
christh21
 
Posts: 11
Joined: 13. September 2004 04:30

Postby Killerfrog » 06. February 2006 00:23

well thx, but i'm running it under Windows, so is it the same thing??
Killerfrog
 
Posts: 75
Joined: 18. December 2004 21:16

Postby christh21 » 07. February 2006 04:33

Just check the php5 extensions folder for 'eaccelerator.dll'. If they didn't compile it for linux I doubt there is a Windows version either.
christh21
 
Posts: 11
Joined: 13. September 2004 04:30

Postby Killerfrog » 07. February 2006 04:39

ok thx then. I'll wait for next version of XAMPP so!
Killerfrog
 
Posts: 75
Joined: 18. December 2004 21:16

Postby foxxx428 » 14. February 2006 11:14

hmmm, mine works as intended although I use both eAccelerator and zend. Try this.

Code: Select all
[eAccelerator]
;extension=eaccelerator.dll
zend_extension_ts="c:\apachefriends\xampp\php\ext\eaccelerator.dll"
zend_extension="c:\apachefriends\xampp\php\ext\eaccelerator.dll"
eaccelerator.shm_size = "64"
eaccelerator.cache_dir = "C:\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "0"
eaccelerator.debug = "0"
eaccelerator.check_mtime = "1"
eaccelerator.filter = ""
eaccelerator.shm_max = "0"
eaccelerator.shm_ttl = "0"
eaccelerator.shm_prune_period = "0"
eaccelerator.shm_only = "0"
eaccelerator.compress = "1"
eaccelerator.compress_level = "9"
eaccelerator.keys = "shm_and_disk"
eaccelerator.sessions = "shm_and_disk"
eaccelerator.content = "shm_and_disk"
;eaccelerator.admin.name =
;eaccelerator.admin.password =


and then for zend,

Code: Select all
[Zend]
zend_extension_ts = "C:\apachefriends\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\apachefriends\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =


I also use the zip package and I see you use an installer so I'm not sure if they included it in the installer.
User avatar
foxxx428
 
Posts: 33
Joined: 20. December 2004 22:21

Postby Killerfrog » 14. February 2006 23:00

well thx, but i've tried your settings and had a lot of bugs. It's probably cause php 5.1 isn't supported by Zend or eaccelerator. I'll wait for next release !
Killerfrog
 
Posts: 75
Joined: 18. December 2004 21:16


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests