Where do I put my files?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Where do I put my files?

Postby JillC » 29. January 2006 10:45

I can't find where to place my files so that I can open them.

If I go to HTTP://localhost is brings up the XAMPP page. The links from this page works fine. But it seems no matter where I place my files or folders that I want to use, they can't be located.

I followed the instructions and installed XAMPP on D:/Program Files/xampp

and then followed all the instructions in the security section.

So, where ??
JillC
 
Posts: 8
Joined: 29. January 2006 10:29

Postby KingCrunch » 29. January 2006 13:18

htdocs-dir
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby JillC » 30. January 2006 02:38

D:/Program Files/xampp/htdocs/xampp
D:/Program Files/xampp/htdocs/xampp/MyFiles
D:/Program Files/xampp/htdocs/MyFiles

They don't show up.
Error 404
JillC
 
Posts: 8
Joined: 29. January 2006 10:29

Postby Clatch » 30. January 2006 02:46

D:/Program Files/xampp/htdocs/

If this is in fact your htdocs directory, you could place your index.html file in that directory. Then go to your browser and type:

http://localhost/index.html

If you placed your files in a subdirectory of the htdocs folder, you woul dhave to include that in your http line.

http://localhost/subfolder/index.html

hope that makes it a bit clearer for you. The server has to be running for the localhost to work. Run your Xampp control panel and double check that this is the case.
Clatch
 
Posts: 4
Joined: 28. January 2006 02:17
Location: Portland, Oregon

Postby JillC » 30. January 2006 03:33

D:/Program Files/xampp/htdocs/xampp

http://localhost/ or http://localhost/xampp shows up xamp page

D:/Program Files/xampp/htdocs/phptests

http://localhost/phptests/first.php

shows .....
Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
01/30/06 10:18:39
Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1
JillC
 
Posts: 8
Joined: 29. January 2006 10:29

Postby WorldDrknss » 30. January 2006 03:40

http://www.worlddrknss.blogdns.org <-- XAMPP Tutorials -- Now with flash videos and live support.
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby JillC » 30. January 2006 04:55

I uninstalled the program, restarted my PC and reinstalled it.

This time, before going through any security checks, I moved some files and folders into the htdocs folder - IT WORKS!!!

I rechecked my security settings and so far I've left the SSI deactivated and it's all working fine. My next problem is to get Dreamweaver to talk to it .... so, I'll be back later I guess.

Thanks for attempting to help, folks.
JillC
 
Posts: 8
Joined: 29. January 2006 10:29

Postby KingCrunch » 30. January 2006 08:38

D:/Program Files/xampp/htdocs/xampp

http://localhost/ or http://localhost/xampp shows up xamp page

Apache use the index-file in htdocs, if it exists, if not, he goes to xampp-start
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests