Installing symfony with PEAR error: Permission denied

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing symfony with PEAR error: Permission denied

Postby Jose222 » 26. January 2006 22:04

I'm trying to install symfony through PEAR:

C:\Program Files\xampp\php\pear>pear install symfony/symfony-alpha
downloading symfony-0.7.578.tgz ...
Starting to download symfony-0.7.578.tgz (1,227,601 bytes)
................................................................................done: 1,227,601 bytes
downloading pake-1.0.89.tgz ...
Starting to download pake-1.0.89.tgz (16,502 bytes)
...done: 16,502 bytes
permission denied (rename): C:\Program Files\xampp\php\pake.bat
ERROR: commit failed
permission denied (rename): C:\Program Files\xampp\php\symfony.bat
ERROR: commit failed

C:\Program Files\xampp\php\pear>


I run into this problem with xampp 1.5.1 yesterday. I though it had to do with the upgrade of the PEAR installation, since that had changed the configuration (I didn't know at the time) and made some paths point to the wrong places.

I am now running a fresh installation of xampp 1.5.2 beta 1, where PEAR is the latest version already and an upgrade is not necessary, but the problem persists. Can any one help in pointing out what could be causeing the "permission denied (rename)" error?

Thanks,

Jose
Jose222
 
Posts: 4
Joined: 26. January 2006 21:46

Postby Jose222 » 31. January 2006 21:18

Just in case anyone comes through this, the problem might be the use of spaces in the path to xampp. I installed the application on the root C:\ drive and everything went fine with symfony. But then I had the same problem with PHPDocumentor (PHPDoc), another file not being renamed. I renamed/deleted the relevant PHPDoc files manually and all is working fine.

And apart from the workaround, the solution might be either in PHP or PEAR (could also be in the installation scripts of symfony/PHPDoc for all I know). I could only find this old PHP bug as being somewhat related:

http://bugs.php.net/bug.php?id=22446&edit=1

Hope that helps someone else.

Best regards,

Jose
Jose222
 
Posts: 4
Joined: 26. January 2006 21:46


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests