"Object not found" wrong URLs!!!!!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

"Object not found" wrong URLs!!!!!

Postby bfr » 15. January 2006 00:54

Note: I have version 1.5.1

When I go to http://localhost/perl/modperl.pl (these are the link on the perl-info file) and http://localhost/asp/loop.asp I get this error:

Object not found!
The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
01/14/06 17:46:11
Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1

I checked in the htdocs folder (and htdocs/xampp folder), and there isn't even a perl folder or an asp folder (the links say http://localhost/perl/modperl.p). There is a modperl folder in htdocs and a modperlasp folder in which there are the loop.asp and modperl.pl files though. When I type in http://localhost/modperl/modperl.pl and http://localhost/modperlasp/loop.asp manually, the correct code doesn't show up. I think it was interpreted as just plain HTML, even though my apache server os running. Here is what the modperl.pl file outputted:

Code: Select all
use CGI::Carp qw(fatalsToBrowser); use English; $module = $ENV{'MOD_PERL'}; print "Content-Type: text/html\n\n"; print ''; print ''; print ''; print ''; print ''; print ''; print "

PERL $] + $module

\n"; print 'Directory for MOD PERL => [..] \xampp\htdocs\modperl => http://localhost/perl/modperl.pl

'; print 'Directory for PERL ASP => [..] \xampp\htdocs\perlasp => http://localhost/asp/loop.asp

 
 
'; use DBI; @drivers = DBI ->available_drivers; print "Available drivers are:
"; foreach (@drivers) { print "$_
"; } print '

 
 
'; print ""; print "";


Here is what the loop.asp file outputted:

Code: Select all
Testing ASP with a loop incrementing the text size:
Size =
 


Please help - something is definitely wrong.
Last edited by bfr on 15. January 2006 01:08, edited 1 time in total.
bfr
 
Posts: 3
Joined: 03. December 2005 20:02

Postby Wiedmann » 15. January 2006 01:04

Which version of XAMPP and Perl addon?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Versions

Postby bfr » 15. January 2006 01:09

I have XAMPP 1.5.1 and Perl 5.8.7-2.2.0

(The latest versions availible.)



EDIT: Nevermind, terribly sorry to bother, it's that the apache server didn't restart. I restarted it now. Thanks for your support.

(This is about the fastest anybody has answered one of my questions on a support forum)

By the way, do you know when Python, Tomcat, and Cocoon will be ready for XAMPP 1.5.1?
bfr
 
Posts: 3
Joined: 03. December 2005 20:02

Postby Wiedmann » 15. January 2006 01:26

By the way, do you know when Python, Tomcat, and Cocoon will be ready for XAMPP 1.5.1?

Sorry, I don't know. But I think, Kay is working on them.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 69 guests