Apache won't start..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby Groffy77 » 17. January 2006 01:10

Well when reinstalling, it says that port 80 is in use or something like that, this happens when starting apache as a service.
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby Groffy77 » 17. January 2006 03:19

I have looked at every guide I found. Nothing tells me how to fix my problem. Theres a file called 'inetinfo' in 'C:\WINDOWS\system32\inetsrv\inetinfo.exe' thats taking port 80 and port 443 which apache needs. How do I stop this file from running, and what is it?
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Also having problem w/Apache

Postby tedkt » 17. January 2006 06:29

I'm having much of the same problem. I am a newbie w/XAMPP and have much to learn. I do understand the frustration, but I want to persavere. I have been searching the forum and have not been able to find the answers yet. Maybe someone could help point me in the right direction. I have installed XAMPP on Windows XP. I am unable to connect to http://localhost (or https:/...) also get an error msg NET HELPMSG 3547 at command prompt somehow?? I have uninstalled and reinstalled XAMPP. While using the XAMPP control panel I was able to see "running" in a green highlighted box next to start buttons & was able to access admin for MySql & FileZilla - but never got it under Apache. I ran setup_xampp.bat and also the xampp-portcheck which revealed status for Apache was 'free', but FileZilla & MySql were connected.
This is my first post, any help will be appreciated.

Ted

:lol:
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby cj_nza » 17. January 2006 08:12

Under your services see if there is a service calles IIS Admin. If it is started, stop this service and set the startup type to manual.

You can use the XAMPP_portcheck utility distributed with XAMPP to see if your ports 80 and 443 are free. If both these ports are free try starting Apache.
cj_nza
 
Posts: 53
Joined: 06. September 2005 11:49

Postby deanosrs » 17. January 2006 13:04

Groffy77 wrote:I have looked at every guide I found. Nothing tells me how to fix my problem. Theres a file called 'inetinfo' in 'C:\WINDOWS\system32\inetsrv\inetinfo.exe' thats taking port 80 and port 443 which apache needs. How do I stop this file from running, and what is it?


I'm not an expert on this stuff, but sounds like spyware to me. try running adaware and spybot then run xampp.
deanosrs
 
Posts: 8
Joined: 13. January 2006 20:27

service settings?

Postby tedkt » 17. January 2006 20:17

Thanks for the quick response!

Are you referring to the service settings in the control panel? There is an ISSVC running but no IIS admin.


OK I did get Apache to start!!!! Stupid mistake I made was that the XAMPP folder was in another folder....stupid,stupid,... So I moved the XAMPP folder to the C:/ directory and ran setup again and control panel shows Apache, MySql & FileZilla running:) . I still have NO luck with http://localhost, but learning ! Next advice?
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby Groffy77 » 17. January 2006 20:38

How do I check my services for the IIS Admin thing?
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Groffy

Postby tedkt » 17. January 2006 21:22

Groffy,

I opened the control panel (xampp-control.exe) and then clicked on 'settings' button (top of control panel), then the service SETTINGS panel popped up and I cklicked on 'SCM' button and a SERVICES(Local) Window popped up with services. You can click on them for info or start/stop some services such as MySQL. But I am wondering if this is what was referred to, or am I way off?

Ted :roll:
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby Groffy77 » 17. January 2006 23:05

Thanks!

Now I'm at the same place as you, getting a "Page Not Found" at localhost.
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

grrrrrr!

Postby tedkt » 18. January 2006 03:13

The latest:

I keep getting this error msg when trying to http://localhost on my browser;


The browser was unable to connect to the specified site, even though it exists. This may be because the site does not accept connections from your computer, the service may be down, or the site does not support the service or port that you tried to connect to.


So I figure maybe my firewall is holding me up, so I upate all the ports for ftp,http,pop3...etc w/tcp port#s. I also noticed Apache no longer stays running. It keeps stopping according to XAMPP control panel.

I guess I'll try a few more things than take some time off. I forgot what I needed XAMPP for, oh yeah so I wouldn't get frustrated with PHP/MySQL on
ISP server....well that shows me!



:twisted:
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby tedkt » 18. January 2006 04:53

Yes, I'm still at it... but it WORKED, I got the http://localhost to open. BUT I tried it on my laptop. I need to get it on my PC. I did however download the exe instead of the zip file.

I think I will change my security settings(under the Internet properties) in the Windows control panel>internet options back to 'default'. I'll keep ya'll posted. If we can figure this out it will save people a lot of hair pulling for the next XAMPP victims.

:P
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

IT'S ALIVE!!!

Postby tedkt » 18. January 2006 05:16

IT'S ALIVE!!! It works!!!!! Finally after only six hours. How? Read on...

I deleted/uninstalled XAMPP and then re-installed the self-extracting zip file(instead of the zip file) and went thru the startup procedure as per usual and *bang* IT'S ALIVE!!!!! Who's your daddy!

Let me know if you get it going Grof.




:D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby Groffy77 » 18. January 2006 05:50

Yay! Uninstalled then installed and it works! Woo, thanks you guys for all your help!

Ted, glad you got it working! :D
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby tedkt » 18. January 2006 13:12

Glad to hear it! Now how do we use this beast 8)
Thank you!
tedkt
 
Posts: 8
Joined: 17. January 2006 05:41

Postby Groffy77 » 18. January 2006 21:48

Well if you go into the xampp directory, theres phpmyadmin for mysql databases. Also the xampp directory has all the settings. Remember when installing any script the mysql username will be 'root' and the password will be what you set in the settings.

Enjoy! Its great when it works, I've been using it for the last year. :D
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests