Apache won't start..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start..

Postby Groffy77 » 14. January 2006 19:19

Hello! I have been having extremely annoying trouble with xampp. This is the first problem I've ever had with it.

When I press start for apache in the control panel, apache starts, but then quits within a second. Mysql starts fine sometimes, but does the same very often.

For some reason they won't start as a service. I've reinstalled xampp, but am very worried about losing my MySQL databases, as they have a coded crap from vB and IPB on them. Which is currently not done, or saved so if I lose it I will lose over $1000 of profit.

How do I fix this? Please help! Thanks!
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Hi

Postby dannyc3 » 14. January 2006 20:07

I have a very similar problem, which normally accurs when i have edited something, namely the httpd.cfg.

The solution i have found is to goto your xampp dir and click on the apache start.bat

If it does not start through the control panel chances are it will give you an error in this screen. Main causes i have found have been bad syntax and spelling mistakes in the cfg file.

Im no expert and am just going of my own experience, hope this help!

Good luck :wink:
dannyc3
 
Posts: 12
Joined: 14. January 2006 15:18

Postby WorldDrknss » 14. January 2006 21:24

this will also happen if you config Virtual Host or SSL incorrectly

http://www.worlddrknss.blogdns.org <-- XAMPP Tutorials
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Groffy77 » 14. January 2006 23:40

I don't configure anything. I don't even know what Virtual Host and SSL are.

Heres what I get from the apache_start.bat file.

Image
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby Groffy77 » 15. January 2006 17:44

WorldDrknss wrote:this will also happen if you config Virtual Host or SSL incorrectly

http://www.worlddrknss.blogdns.org <-- XAMPP Tutorials


That xampp tutorial place didn't help at all. :(
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby dannyc3 » 15. January 2006 18:39

in ur httpd.cfg make sure u have

#listen [ip number]
port 80

on or around line 53

im guessing you have removed the #

Hope this helps ;)

[/code]
dannyc3
 
Posts: 12
Joined: 14. January 2006 15:18

Postby Groffy77 » 15. January 2006 18:41

Wheres the httpd.cfg file?
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby dannyc3 » 15. January 2006 18:44

oh dear, i suggest you read this

http://community.apachefriends.org/f/viewtopic.php?t=14173

Hope that helps
dannyc3
 
Posts: 12
Joined: 14. January 2006 15:18

Postby Groffy77 » 15. January 2006 18:45

Ok found it.. and its not on the 53 line. I found this on line 111-120.

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:80
Listen 80


If someone could mabye come on Remote Assistance or something to help me out. I am getting extremely frustrated and impatient.
Last edited by Groffy77 on 15. January 2006 18:48, edited 1 time in total.
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby dannyc3 » 15. January 2006 18:47

so its working now?
dannyc3
 
Posts: 12
Joined: 14. January 2006 15:18

Postby Groffy77 » 15. January 2006 18:48

No.

If someone could do remote assistance to fix it for me, that would be great. I am not a nuts and bolts guy and have no idea what to do.
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby dannyc3 » 15. January 2006 18:56

As i suggested before you should check out that link i posted.

It will help you getting apache started, learning is all part of the fun of running your own webserver.

If you dont want to learn and you just want somebody to do it for you i suggest you pay for someone to host your site for you ;)

Good luck!
dannyc3
 
Posts: 12
Joined: 14. January 2006 15:18

Postby Groffy77 » 15. January 2006 18:59

I use xampp to build skins easier than using my webhost. It helps being able to see thumbnails of images while overighting them and stuff. Its a lot quicker and has a lot less problems.

I don't build skins using my website, its very slow since I refresh the page like 100 times in 30 seconds.

If anyone can help, it would be greatly appreciated!
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby Groffy77 » 16. January 2006 19:06

Does anyone want to help me?

The support here is lame.
Groffy77
 
Posts: 14
Joined: 14. January 2006 19:06

Postby deanosrs » 16. January 2006 19:16

Mate, you've been given a free web server that's bloody good when you get it working, I don't think you're in a position to call the support here lame. People have given you links to articles that will ultimately lead you to a solution, almost certainly, yet you can't be bothered to read them and understand the problem for yourself, rather you just demand someone come on remote assistance. My advice would be to read those articles and see if this helps.

If not, try re-installing xampp. It gives you an option during the uninstall to leave htdocs and the mysql db's so you won't lose any data.
deanosrs
 
Posts: 8
Joined: 13. January 2006 20:27

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests