Previlege to create table in MySql???

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Previlege to create table in MySql???

Postby kidkitkit » 11. January 2006 18:33

I used the user name "pma" (with no password) to login the phpMyAdmin page. However, it said that i have no previlege to create a database.
Why is it so ???
Also, i heard from a friend that i can try to login the phpMyAdmin page by using "root" (without any password). I tried it. But seems it doesn't work too.
Can anyone help ?
kidkitkit
 
Posts: 6
Joined: 11. January 2006 18:22

Postby Wiedmann » 11. January 2006 22:49

"pma" is only a service (internal) user for phpMyAdmin and not for general use. You must use "root".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kidkitkit » 12. January 2006 01:30

but i cannot use "root" to go to the phpMyAdmin page
kidkitkit
 
Posts: 6
Joined: 11. January 2006 18:22

Postby Wiedmann » 12. January 2006 01:34

Then you have changed something.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kidkitkit » 12. January 2006 01:51

then which part should i check in order to seek out the problematic part ?
kidkitkit
 
Posts: 6
Joined: 11. January 2006 18:22

Postby Wiedmann » 12. January 2006 01:56

then which part should i check in order to seek out the problematic part

A fresh XAMPP installation comes with the user "root" an no password. I've you can not log in with that user (access denied?) you have changed the password by yourself...

(Check your mind and remember that password ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kidkitkit » 12. January 2006 02:11

access denied
here is part of the code in \phpMyAdmin\confid.inc.php

=============================================
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension'] = 'mysql'; // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = 'pma'; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables).
// The controluser is also
// used for all relational
// features (pmadb)
$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = ''; // MySQL password (only needed
==============================================

the password of the "root" user has been set to empty
but cannot go to the phpMyAdmin page using "root"
kidkitkit
 
Posts: 6
Joined: 11. January 2006 18:22

Postby Wiedmann » 12. January 2006 02:43

the password of the "root" user has been set to empty

That's not important. Because the MySQL users/password are stored directly in MySQL and not in a config file (for a "simply" PHP script).

BTW:
That's not a clean XAMPP installation...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kidkitkit » 12. January 2006 20:28

thx Wiedmann
Eventually i had my xampp uninstalled n reinstalled
And now it works :D
kidkitkit
 
Posts: 6
Joined: 11. January 2006 18:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests