File Permission problem:

Problems with the Windows version of XAMPP, questions, comments, and anything related.

File Permission problem:

Postby klane » 09. January 2006 13:09

I've installed Xampp but i'm having problems changing the file permissions to what i need them to (666 etc.) i've been connecting to my localhost via my ftp client but when it comes to changing them it will not do so what so ever, is there a reason? do i need to change something in a file somewhere to allow me to do so? any help would be greatful.

thanks, Klane.
klane
 
Posts: 2
Joined: 09. January 2006 12:39

Postby Vineman » 09. January 2006 17:10

Windows does not use permissions.
Vineman
 
Posts: 2
Joined: 29. December 2005 22:20

Postby klane » 09. January 2006 18:37

i know that, but i can't write to file unless its set to a certain thing, so how do i by pass that in windows?
klane
 
Posts: 2
Joined: 09. January 2006 12:39

Postby taustin » 09. January 2006 20:10

That's usually handled with account settings on the ftp server on Windows servers.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby Perkele » 10. January 2006 14:56

Right click on files you want to write to and un-select Read-only option ;)
Perkele
 
Posts: 1
Joined: 10. January 2006 14:52

Postby Buxellistip » 31. March 2006 08:08

Hi
i try to uncheck read only option (it is gray) but when i choose apply and go to propertie again it is gray again?
Please someone help
TY
Buxellistip
 
Posts: 9
Joined: 31. March 2006 07:33
Location: Slovenia

Postby Wiedmann » 31. March 2006 09:15

i try to uncheck read only option (it is gray) but when i choose apply and go to propertie again it is gray again?

Than you have made this on a directory and not on files.

BTW:
There is no need to make special permissions on Windows like on *nix for scripts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Buxellistip » 31. March 2006 09:29

Files are unchecked which is fine but folders are not. Im trying to do this because it gives me:
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at C:\xampp\htdocs\includes\application_top.php:275) in C:\xampp\htdocs\includes\application_top.php on line 275
Buxellistip
 
Posts: 9
Joined: 31. March 2006 07:33
Location: Slovenia

Postby Wiedmann » 31. March 2006 09:32

Files are unchecked which is fine but folders are not.

Right, that's the normal and documented Windows behaviour.

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at C:\xampp\htdocs\includes\application_top.php:275)

Then you have an error in your script, like the error message told you.

Read the PHP-Manual about sessions and header:
You can not send a header (like a session cookie), if there was allready an output in your script.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests