garbage after install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

garbage after install

Postby stjepan » 27. December 2005 15:45

Hi,

I installed Apache, MySQL, PHP, PHP Nuke on MS XP Pro PC. I read Install.txt and did created database, then mysql nuke < nuke.sql.

When in Firefox I opened file admin.php and I get screen full of garbage like this:
sql_numrows($db->sql_query("SELECT * FROM ".$prefix."_authors")); if ($first == 0) { $pwd = md5($pwd); $the_adm = "God"; $db->sql_query("INSERT INTO ".$prefix."_authors VALUES ('$name', '$the_adm', '$url' etc etc

So, it seems that php cannot be processed. On the other hand, when I enter http://localhost XAMPP I get plenty of information:

PHP Version 5.0.5

System Windows NT GANDALF 5.1 build 2600
Build Date Oct 25 2005 17:26:15
Configure Command cscript /nologo configure.js "--enable-snapshot-build"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\Program Files\xampp150\xampp\apache\bin\php.ini
PHP API 20031224
PHP Extension 20041030 etc etc

Which means, I believe, that php IS installed. However, only http://localhost gives me information, I cannot for example write a simple document with only phpinfo() - I end up with blank page.

I have dll in System and System32 folders.

Does someone has any advice? Do I have to somewhere specify some path (XAMPP is in Program Files although in Readme file states that it should be in root, but installer doesn't allow me to install in C: )? Do I have to specify some global variable?

Thank you.
stjepan
 
Posts: 2
Joined: 27. December 2005 15:26

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests