They point their finger towards you.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

They point their finger towards you.

Postby maj » 22. December 2005 19:29

Hi

I don't know if this is acceptable or not, but I'm posting here to discuss a problem I'm experiencing with dotProject installation. The reason I post it here is that after seeking help in their forum they said it might be XMAPP which is causing the problem :oops: and suggest that maybe using TheSaintWAMP would be a better idea.

Here is the error I get when I try to install dotProject:
Creating new Database
Installing database
There were 199 errors in 200 SQL statements
FATAL ERROR: Connection to database server failed


A principal contributer to dotProject forums dignosted the situation as:
Seems like mysql is not running.


Here is the url to the topic discussing the problem in dotProject forum:
http://www.dotproject.net/vbulletin/sho ... php?t=4121

Please help.
It's funny how a mere semicolon (or the lack of one) could be the source of your agony for days.
User avatar
maj
 
Posts: 5
Joined: 22. December 2005 18:46

Postby Wiedmann » 22. December 2005 19:50

Code: Select all
.;D:\apachefriends\xampp\

And I changed them to:
Code: Select all
D:\apachefriends\xampp\

as I thought the leading .; chars have been put in there because of a bug in XMAPP.

The complete line you changed please...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maj » 22. December 2005 21:20

I've changed two lines in D:\apachefriends\xampp\php\php.ini

Code: Select all
; upload_tmp_dir = ".;D:\apachefriends\xampp\tmp"
upload_tmp_dir = "D:\apachefriends\xampp\tmp"

; session.save_path= ".;D:\apachefriends\xampp\tmp"
session.save_path= "D:\apachefriends\xampp\tmp"


And one line in D:\apachefriends\xampp\apache\bin\php.ini

Code: Select all
;session.save_path= ".;D:\apachefriends\xampp\tmp"
session.save_path= "D:\apachefriends\xampp\tmp"
It's funny how a mere semicolon (or the lack of one) could be the source of your agony for days.
User avatar
maj
 
Posts: 5
Joined: 22. December 2005 18:46

Postby Wiedmann » 22. December 2005 21:41

Right. This was a bug in this (early) XAMPP version.

And now MySQL:
- phpMyAdmin
- XAMPP status
- XAMPP cd demo
are working?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maj » 22. December 2005 22:01

Well yes and no.
    phpMyAdmin works fine.
    XAMPP Status works fine.
    XAMPP cd demo returns error:

CD Collection (Example for PHP+MySQL+PDF Class)
A very simple CD programm.

CD list as PDF document.


Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in D:\apachefriends\xampp\htdocs\xampp\cds.php on line 65
Could not connect to database!
Is MySQL running or did you change the password?


And root@localhost is password protected, not as the warning says (using password: NO).

Will an upgrade solve the problem? and which is the current stable for Windows?

Thanks
User avatar
maj
 
Posts: 5
Joined: 22. December 2005 18:46

Postby Wiedmann » 22. December 2005 22:53

And root@localhost is password protected, not as the warning says (using password: NO).

So the error message is ok:
The script (cd demo) is using the user root and no password for the MySQL connection, but the user root have a password in MySQl --> access denied

phpMyAdmin works fine.
XAMPP Status works fine.

Well, so there is no problem with MySQL and PHP.

Will an upgrade solve the problem?

You have no problem. All is working correct. Maybe you make an error during the install from that program (dotProject) or there is a problem with the prerequists from dotProject (Apache-, MySQL-, PHP-Version, PEAR...).

BTW:
This was a fresh installation? Because uninstall an install the newest version is the easiest way from such a old version.

and which is the current stable for Windows?

http://www.apachefriends.org/en/xampp-windows.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maj » 22. December 2005 23:18

You have no problem. All is working correct.


Have you changed your mind? you said this was because of a bug.

Does that mean upgrading will be of no effect? (I'm downloading the new release)

Well, thanks anyway.
User avatar
maj
 
Posts: 5
Joined: 22. December 2005 18:46

Postby Wiedmann » 22. December 2005 23:53

you said this was because of a bug.

No. I don't told you this was because of a bug. I only told you this two entries in the php.ini was a "bug". BTW. the most software can work with the "wrong" entries. And if not, you get only a error message from the session handler or an upload script. The two "wrong" paths have nothing to do with MySQL.

In detail:
- The session.save_path ".;.\xampp\tmp" is a correct setting for this directive, But some scripts doesn't know this and you get an error.
- The upload_tmp_dir was wrong. But PHP automatically use the windows temp path instead. So not a big problem if a script is using standard functions.

And in the end, you have correct this problem by yourself before the problem with MySQL and dotProject happend.

And if you can see: phpMyAdmin is working on your XAMPP, or not?. And phpMadmin is a "big" PHP script for administration a MySQL server
--> no problem with PHP, no problem with MySQL

Does that mean upgrading will be of no effect? (I'm downloading the new release)

I don't know anything about this software and the system requirements it need. So, no idea what is the problem.


Is there no debug mode in dotProject to see the real PHP error message and of course the real MySQL error message?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingCrunch » 23. December 2005 00:08

I can say:
Im using the actual XAMPP for Win32 with the actual dotProject for about one hour ;) I had some probs with the compatibility to PHP5, but now all is working fine even with MySQL without any further problems.

Maybe you want to try to install DP from scratch. Then you have to remove "includes/config.php", because if you dont remove this file, the system thinks there is already a running configuration and tries to upgrade but not to reinstall. This has caused some errors with MySQL at my environment.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby maj » 23. December 2005 01:49

First of all a big 'thank you' to both Wiedmann and KingCrunch.

And then:

Wiedmann
    1. currently I meet all software and system requirements for dotProject as verified by one of the developers
    2. I haven't been able to install a working copy of dotProject yet so I don't know if a debug mode is available or not - I'm going to search thire forum to see if there is one.
    3. I'm patient and won't give way and next on my list I have uninstalling XMAPP and doing a clean install of the latest version.


KingCrunch
I will certainly reinstall dP after I have upgraded to XMAPP 1.5.0-pl1.
And the problems regarding PHP5 compatibility - could you share what they are and how to avoid them? - it might take me days if I'm to get passed them on my own. :cry:
User avatar
maj
 
Posts: 5
Joined: 22. December 2005 18:46

Postby KingCrunch » 23. December 2005 02:45

I made the following changes and it seems to be working:

tasks.php - find and replace '$from .= ", user_tasks";' with '$from = "user_tasks, tasks";'

todo.php - swap lines 91 & 92 so user_tasks comes before tasks:
$q->addTable('user_tasks', 'ut');
$q->addTable('tasks', 'ta');

I had a look at the forums page as well but I'm not actually that mysql savvy and since we aren't using it I didn't take the time to figure it out.

hope this helps someone!
Taken from DotProject-Forum.

----

Update:
Its a compatibility-problem in MySQL, not in PHP. My mistake ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests