Virtual Hosts problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Virtual Hosts problem

Postby quikstor » 14. December 2005 13:31

I am currently having a problem where my virtual hosts arent working at all, and it's only recognizing the first entry in the file.

Here is my list of vhosts...It's kinda mixed up because I was trying different things, but nothing was working.

# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
#<VirtualHost *:80>
# ServerAdmin webmaster@dummy-host.example.com
# DocumentRoot /www/docs/dummy-host.example.com
# ServerName dummy-host.example.com:80
# ErrorLog logs/dummy-host.example.com-error_log
# CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName quikstor.com
DocumentRoot C:\Apache\xampp\htdocs\quikstor
CustomLog logs/quikstor_log combined
ErrorLog logs/quikstor-error_log
</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName www.quikstor.com
DocumentRoot C:\Apache\xampp\htdocs\quikstor
CustomLog logs/quikstor_log combined
ErrorLog logs/quikstor-error_log
</VirtualHost>

<VirtualHost 127.0.0.1:80>
ServerAdmin donald@quikstor.com
ServerName ecommerce.quikstor.com
DocumentRoot "c:/apache/xampp/htdocs/eCommerce"
CustomLog logs/ecommerce_quikstor_log combined
</VirtualHost>


<VirtualHost *:80>
ServerAdmin donald@quikstor.com
ServerName grandcentral.quikstor.com
DocumentRoot "C:/Apache/xampp/htdocs/grandcentral"
CustomLog logs/grandcentral_log combined
</VirtualHost>

<VirtualHost *>
ServerName ecommerce.goldenstatestorage.com
ServerAdmin ryan@ojaioil
DocumentRoot C:\Apache\xampp\htdocs\gscam
CustomLog logs/gs_cam_log combined
</VirtualHost>

<VirtualHost *>
ServerName laderaranch.quikstor.com
ServerAdmin info@integritywebdesign.net
DocumentRoot C:\Apache\xampp\htdocs\laderaranch
CustomLog logs/laderaranch_log combined
</VirtualHost>

<VirtualHost *>
ServerName sovran.quikstor.com
ServerAdmin donald@quikstor.com
DocumentRoot C:\Apache\xampp\htdocs\sovran
CustomLog logs/sov_log combined
</VirtualHost>

<VirtualHost *:80>
ServerAdmin dennis@janeanddennis.com
DocumentRoot "C:/Apache/xampp/htdocs/jandd"
ServerName janeanddennis.com
<Directory C:\Apache\xampp\htdocs\jandd>
Options Indexes FollowSymLinks
AllowOverride FileInfo
</Directory>
CustomLog logs/jandd_log combined
</VirtualHost>

<VirtualHost *:80>
ServerAdmin dennis@janeanddennis.com
DocumentRoot "C:\Apache\xampp\htdocs\jandd"
ServerName www.janeanddennis.com
<Directory C:\Apache\xampp\htdocs\jandd>
Options Indexes FollowSymLinks
AllowOverride FileInfo
</Directory>

CustomLog logs\jand_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName www.mountainstorage.com
DocumentRoot C:\Apache\xampp\htdocs\MountainStorage
CustomLog logs/mountainstorage_log combined
</Virtualhost>

<Virtualhost *>
ServerAdmin donald@quikstor.com
ServerName mountainstorage.com
DocumentRoot C:\Apache\xampp\htdocs\MountainStorage
CustomLog logs/mountainstorage_log combined
</Virtualhost>


<VirtualHost *>
ServerAdmin dan@boba-fett.net
ServerName massagebyteaa.com
DocumentRoot C:\Apache\xampp\htdocs/teaa
CustomLog logs/teaa_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin dan@boba-fett.net
ServerName www.massagebyteaa.com
DocumentRoot C:\Apache\xampp\htdocs/teaa
CustomLog logs/teaa_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin dstrand@asrsecurity.com
ServerName asrsecurity.com
DocumentRoot C:\Apache\xampp\htdocs/asr
CustomLog logs/asr_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin dstrand@asrsecurity.com
ServerName www.asrsecurity.com
DocumentRoot C:\Apache\xampp\htdocs/asr
CustomLog logs/asr_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName advancedsecurityresources.com
DocumentRoot /htdocs/asr
CustomLog logs/asr_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin dan@boba-fett.net
ServerName boba-fett.net
DocumentRoot C:\Apache\xampp\htdocs\boba-fett
CustomLog logs/boba-fett_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin dan@boba-fett.net
ServerName www.boba-fett.net
DocumentRoot C:\Apache\xampp\htdocs\boba-fett
CustomLog logs/boba-fett_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName gss.cam.quikstor.com
DocumentRoot C:\Apache\xampp\htdocs\gsscam
CustomLog logs/gss_cam_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin donald@quikstor.com
ServerName gsscam.quikstor.com
DocumentRoot C:\Apache\xampp\htdocs/gsscam
CustomLog logs/gss_cam_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin joker@gothampublicworks.com
ServerName wifflecow.com
DocumentRoot C:\Apache\xampp\htdocs/wifflecow
CustomLog logs/wifflecow combined
</VirtualHost>

<VirtualHost *>
ServerAdmin joker@gothampublicworks.com
ServerName www.wifflecow.com
DocumentRoot C:\Apache\xampp\htdocs/wifflecow
CustomLog logs/wifflecow combined
</VirtualHost>

<VirtualHost *>
ServerAdmin danpublic@gmail.com
ServerName burningdan.net
DocumentRoot C:\Apache\xampp\htdocs/burningdan
CustomLog logs/burningdan_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin danpublic@gmail.com
ServerName www.burningdan.net
DocumentRoot C:\Apache\xampp\htdocs/burningdan
CustomLog logs/burningdan_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin danpublic@gmail.com
ServerName hitrecord.org
DocumentRoot C:\Apache\xampp\htdocs/hitrecord
CustomLog logs/hitrecord_log combined
</VirtualHost>

<VirtualHost *>
ServerAdmin danpublic@gmail.com
ServerName www.hitrecord.org
DocumentRoot C:\Apache\xampp\htdocs/hitrecord
CustomLog logs/hitrecord_log combined
</VirtualHost>

# Win32DisableAcceptEx


This build of Xampp is an upgrade from my old apache 1.3 installation, and I really want it to work. This virtual host is copyed out of the old install with some minor path changes. I installed XAMPP into c:\apache\

It pulls up the first entry just fine, but thats the only thing it ever pulls up. Everything you go to ends up just going to that first entry. Why is it not recognising my vhosts? I am modifying the httpd.conf in the \xammp\conf folder, is there another place I have to modify. I am starting and stoping the apache server each time I try something new, but nothing works. HELP!
quikstor
 
Posts: 3
Joined: 14. December 2005 13:21

Postby RoN81 » 14. December 2005 17:23

Hello,

can you tell me what operating system you are using?
I got the same problem like you but not with XAMPP. Ich also only could reach the first virtuall host. I solved the problem with using different IP adreses.
RoN81
 
Posts: 17
Joined: 11. December 2005 15:33
Location: C-Town

Postby quikstor » 14. December 2005 19:33

This is on windows2000server. I have a firewall on this computer, but my virtual hosts were working fine on my old 1.3 apache build, but could a firewall be blocking http headers?
quikstor
 
Posts: 3
Joined: 14. December 2005 13:21

Postby quikstor » 19. December 2005 20:33

I found out the problem. I was adding my vhosts from an old file. When I went through and added them one by one always adding them at the bottom of the file it worked fine.
quikstor
 
Posts: 3
Joined: 14. December 2005 13:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests