Alias problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Alias problem

Postby Wick » 08. December 2005 17:14

I have a problem to create alias.

I can't create an alias outside the htdocs folder of xampp.
Did anybody had this problem ?

Here is my alias :

Code: Select all
Alias /dev "D:/www/"
<Directory "D:/www">
    Order allow,deny
    Allow from all
</Directory>


But, it doesn't work.
Thanks a lot for your answer.
Wick
 
Posts: 10
Joined: 23. November 2005 14:05

Postby Wiedmann » 08. December 2005 17:25

But, it doesn't work.

Why not? Browser error message, error.log, ...?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wick » 08. December 2005 21:35

I realized after posted this message that I haven't put any precision on my message... Sorry about that.

I have a 403 error (forbidden access) on my screen, but if I put my alias to a folder into "htdocs", it works really good...

I think I have a problem in my httpd.conf....

Thanks you for your answer et for your help.
Wick
 
Posts: 10
Joined: 23. November 2005 14:05

Postby KingCrunch » 08. December 2005 22:01

Code: Select all
Alias /dev "D:/www"
<Directory "D:/www">
    Order allow,deny
    Allow from all
</Directory>

When the Alias has no leading slash, the leading slash at the Directory isnt allowed.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Wick » 09. December 2005 09:03

Thanks for your answer but sorry, but i have the same problem.
Wick
 
Posts: 10
Joined: 23. November 2005 14:05

Postby Wick » 12. December 2005 09:03

I added Options FollowSymLinks in my alias but it doesn't work too.

Code: Select all
Alias /dev "D:/www"
<Directory "D:/www">
Options FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>


Does anobody got a solution ?

Thanks a lot.
Wick
 
Posts: 10
Joined: 23. November 2005 14:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests