Apache won't run

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't run

Postby JoanW » 04. December 2005 23:47

I wanted to stop and restart Apache. I went to Start - All Programs - apachefriends - xampp - CONTROL XAMPP SERVER PANEL and stopped Apache from running. But now I can't get it running. It says it is started, but it doesn't run. Even rebooting doesn't fix the problem.

Please advise what I need to do to fix this.

Thank you.
Joan
JoanW
 
Posts: 17
Joined: 31. October 2005 16:32
Location: Hattiesburg, MS USA

Postby JoanW » 05. December 2005 00:41

More information on this problem.
The little apache icon says: Running none of Apache services.
When I click on the icon, and click Start I get this message:

The requested operation has failed!

I have gone into Apache/bin and double clicked on apache.exe. But still, nothing changes.

I went to apache_installer.bat and get this:

Installing Apache2 as an Service
[Sun Dec 04 17:25:40 2005] [error] Apache2: Service is already installed.
Now we Start Apache2 :)
The Apache2 service is starting.
The Apache2 service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.

I go to cmd.exe and input the above and get this:

C:\>NET HELPMSG 3547

A service specific error occurred: ***.


EXPLANATION

A service-specific error occurred.

ACTION

Refer to the Help or documentation for that service to determine the problem.

Is there a way to reinstall only Apache through xampp? Would that help?
JoanW
 
Posts: 17
Joined: 31. October 2005 16:32
Location: Hattiesburg, MS USA

Postby bill oakley » 05. December 2005 07:36

Hmmm., just a quess but did you modify the httpd.conf file in /xampp/apache/conf directory to have it point to a separate directory? Check the httpd.conf fiel and make that both parameters are set to an existing directory.
Make sure both DocumentRoot and Directory are set up properly.

---from httpd.conf file

ServerName localhost:80

#
# UseCanonicalName: Determines how Apache constructs self-referencing
# URLs and the SERVER_NAME and SERVER_PORT variables.
# When set "Off", Apache will use the Hostname and Port supplied
# by the client. When set "On", Apache will use the value of the
# ServerName directive.
#
UseCanonicalName Off

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "c:/apachefriends/xampp/htdocs"

#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory>
Options FollowSymLinks
AllowOverride None
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "c:/apachefriends/xampp/htdocs">

#

One way to set a new diretory at least for a test bed whilst maintaining access to the original xampp pages is to set up a virtual host (very end of httpd.conf file) such as:

#NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
<VirtualHost test:80>
ServerAdmin test@test.com
DocumentRoot j:/www
ServerName test:80
</VirtualHost>

Now you can type in //test and go to your development directory and maintain the original xampp stuff.

If worst come to worse see the httpd.default.conf file
Don't forget to restart apache after changes.
Regards
User avatar
bill oakley
 
Posts: 8
Joined: 01. August 2005 06:55


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests