problems on localhost and Real IP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problems on localhost and Real IP

Postby thankyoume » 21. November 2005 08:32

Dear all,
I have sucessfully installed my xamp on my server. However, I can only view my web file using the http://localhost/. When I enter my computer real ip with http://218.255.xxx.xx . It shown object not found. Can any gentlemen help me to solve the problem? Thanks a lot!!!
thankyoume
 
Posts: 1
Joined: 21. November 2005 08:25

Postby Foxy » 21. November 2005 16:12

Turn off your fiewall or make sure you have something like this on your httpd.conf =

#Listen 12.34.56.78:80
Listen 80
Foxy
 
Posts: 37
Joined: 08. November 2005 21:18

Postby Hunter » 23. November 2005 10:25

Got the same problem with mine. The configuration "Listen 80" is standard.
Am I supposted to put it like this into my browser:

xx.xxx.xxx.xxx:80 ?

edit: have also opened port 80 tcp into my router
Hunter
 
Posts: 32
Joined: 03. September 2005 16:29

Postby deepsurfer » 23. November 2005 10:49

Dear all,
I have sucessfully installed my xamp on my server. However, I can only view my web file using the http://localhost/. When I enter my computer real ip with http://218.255.xxx.xx . It shown object not found. Can any gentlemen help me to solve the problem? Thanks a lot!!!


this ist an routing problem.
your router does not connect from "LAN to INET and back to LAN"
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby Hunter » 23. November 2005 14:38

Wrong with the port then?..
Hunter
 
Posts: 32
Joined: 03. September 2005 16:29

Postby deepsurfer » 23. November 2005 15:13

Hunter wrote:Wrong with the port then?..

no..it is a general routing problem, because "not a problem", it is a network rule.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby investor2006 » 29. November 2005 04:16

the problem is in the router.

I have ADSL from Verizon (in USA) and somehow the ip it's not showing anything when I type my own IP.

I know there is a way to configure the ADSL modem wich is at the same time a router.

Anyone has been able to configure it???
investor2006
 
Posts: 2
Joined: 29. November 2005 04:03

Postby WorldDrknss » 29. November 2005 18:21

If your using that Versalink P.O.S verizon sent you "the modem and router in one" then you will never be able to access your site through your ip. The versalink is setup not to allow any ports to be opened. My suggestion is call verizon and have them send you out a Westell Wirespeed Dual Connect (2100) modem and Linksys Router, and they should do it for free, as they did mine for free, but beware the linksys router verizon sends you drops connection a lot, so I went out and bought a netgear router.
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby WorldDrknss » 29. November 2005 18:23

by the way I went through three or four of them suckers and finally decided to plug my old westell 2100 modem in, intill they sent me out a new westell 2100.
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests