Xampp Mail Problems on a home based server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp Mail Problems on a home based server

Postby Michaelr » 04. November 2005 15:03

I have installed the latest Xampp and Joomla on Windows XP Pro. Everything seems to be working fine, a very nice package! I am running a home based server with a DDNS redirect (dynamic IP)
I am having problems with people registering and not receiving the confirmation email. I have even tried Mass mail... I did not receive an email.

Being relatively new to this and since Xampp is a package, I assumed that the mail function was configured on install. I have searched hi & low for detailed step by step instructions on how to get the mail working. Can someone point me in the right direction please??? I would really like to use a mail program locally, not an ISP mail server. Is this what Mercury is suposed to do?

Any & all help would be greatly appreciated!!
Regards,
Mike
Last edited by Michaelr on 06. November 2005 21:15, edited 1 time in total.
Michaelr
 
Posts: 6
Joined: 04. November 2005 14:48
Location: Canada

Postby prenkema » 05. November 2005 20:12

Go to global configuration of your site, go to e-mail section
and choose SMTP Server, fill in all the fields, like you did for outlook or whatever e-mail client you are using and you should be up and running.

When you don't want to use this ISP account, (why not?) it will become slightly more difficult, please tell me more what you want to achieve, because then the local mail has to be configured and from Joomla you have to send your mail there....
Mister Anderson, suprised to see me ?
prenkema
 
Posts: 1
Joined: 05. November 2005 19:49

I'm not sure why...

Postby Michaelr » 05. November 2005 22:38

Firstly, thank-you very much for your reply :lol:

I guess I don't understand exactly how everything works. I thought that since I am running a home based server I should also be sending and receiving emails from the same home based server?

I did go under global config and am not sure what to put into the fields. I changed it to SMTP.

I am not sure what to put into the mail from... is that my name or my personal email address?
From Name... just my name?
Send mail path? I thought this to point somewhere to a directory on my server... the current path is Linux based?
SMTP Auth... I am guessing no?
SMTP User... is this my personal email address again?
SMTP Password... my password to my personal email address? (My ISP? not server)
SMTP Host... not sure what to put here either...

I am sorry I am not very confident in what I should be putting here. I am guessing that I should not have changed anything else manually... as in the PHP.ini and such, or tried to configure Mercury Mail (is this required BTW?)

Thanks again for your help, and hopefully you can guide me to success!

Just a thought or opinion... with all the things I have been trying (editing PHP.ini and mercury) should I start over from scratch? (again lol)

Thanks,
Mike
Michaelr
 
Posts: 6
Joined: 04. November 2005 14:48
Location: Canada

Duh!!!

Postby Michaelr » 06. November 2005 02:18

I got it working :lol: I guess I couldn't get my mind around the concept of using my personal email account as part of the server, I thought I had to use Mercury.

Thank you very much for all your help, I went back and played with the globals and it works great now.

Regards,
Mike
Michaelr
 
Posts: 6
Joined: 04. November 2005 14:48
Location: Canada

Postby AcCuMuL8r » 13. November 2005 02:21

ok...now if you do not have a personal email account to use how do you set it up to work?
AcCuMuL8r
 
Posts: 4
Joined: 13. November 2005 02:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests