No localhost connections

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No localhost connections

Postby winfidel » 29. October 2005 22:39

I have Window XP-pro, SP2, all updates. I disabled the firewall. I've tried twice installing, then uninstalling with installer, then I tried the manual install. Everything appears to install and start correctly, no errors, log looks OK, configuration has all the right paths. I didn't change anything. Oh, and I don't have IIS or any other servers. The portcheck reports what I expect, all ports either free or assigned to XAMPP programs.

But I cannot ever get either firefox or MSIE to connect to localhost (or http://127.0.0.1/). My hosts file does have the entry localhost 127.0.0.1

Added: I get no error trying to connect, just an infinite timeout, saying "Waiting for localhost..." or "Waiting for 127.0.0.1...".

I'm about to give up and try something else, but I really want to get this one to work. I'm pretty good with computers, but not web servers, and this is getting me down. :-(

I've read the FAQs, and searched Google, with no help.

Can anyone help? Please?

Thanks,

Marty Fried
left coast, USA
winfidel
 
Posts: 3
Joined: 29. October 2005 22:18

Postby WorldDrknss » 30. October 2005 00:35

try connecting with http://localhost and make sure you disable Windows Firewall and open these ports in your software firewall

ftp 21/tcp # File Transfer [Control] (XAMPP: FTP Default Port)
smtp 25/tcp mail # Simple Mail Transfer (XAMPP: SMTP Default Port)
http 80/tcp # World Wide Web HTTP (XAMPP: Apache Default Port)
pop3 110/tcp # Post Office Protocol - Version 3 (XAMPP: POP3 Default Port)
imap 143/tcp imap2 # Internet Message Access Protocol (XAMPP: IMAP Default Port)
https 443/tcp # http protocol over TLS/SSL (XAMPP: Apache SSL Port)
mysql 3306/tcp # MySQL (XAMPP: MySQL Default Port)
AJP/1.3 8009 # AJP/1.3 (XAMPP: Tomcat AJP/1.3 Port)
http-alt 8080/tcp # HTTP Alternate (see port 80) (XAMPP: Tomcat Default Port)

also set your router to use DMZ or again have these ports forwarded to your local ip address eg: 192.168.X.X

ftp 21/tcp # File Transfer [Control] (XAMPP: FTP Default Port)
smtp 25/tcp mail # Simple Mail Transfer (XAMPP: SMTP Default Port)
http 80/tcp # World Wide Web HTTP (XAMPP: Apache Default Port)
pop3 110/tcp # Post Office Protocol - Version 3 (XAMPP: POP3 Default Port)
imap 143/tcp imap2 # Internet Message Access Protocol (XAMPP: IMAP Default Port)
https 443/tcp # http protocol over TLS/SSL (XAMPP: Apache SSL Port)
mysql 3306/tcp # MySQL (XAMPP: MySQL Default Port)
AJP/1.3 8009 # AJP/1.3 (XAMPP: Tomcat AJP/1.3 Port)
http-alt 8080/tcp # HTTP Alternate (see port 80) (XAMPP: Tomcat Default Port)

Did you open XAMPP Control Panel to make sure that Apache and MySQL where indeed running.
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby WorldDrknss » 30. October 2005 00:50

Also one thing I noticed when I was trying to get XAMPP to work is that it works best if you install in your C: eg: C:\xampp\xampp then open your browser and type http://localhost after confirming that Apache and MySql are running and visit the security tab and create a password for XAMPP Directory and MySQL.

Then create a directory called www in your C: eg: C:\www\ and setup virtual host by going to path\apache\conf\httpf.conf scroll to the bottom and setup the virtual host.

My VirtualHost
Code: Select all
#Access your web
NameVirtualHost *:80
<VirtualHost *:80>
    DocumentRoot C:/www/thegamerslounge
    ServerName thegamerslounge.game-host.org
    ServerAlias www.thegamerslounge.game-host.org
</VirtualHost>
#Access XAMPP with virtual Host
<VirtualHost *:80>
    DocumentRoot C:/xampp/xampp/htdocs
    ServerName localhost
</VirtualHost>


but if you want the following then you need to edit the HOST File, this is only if your not going Live on your website.
C:\WINDOWS\System32\Drivers\etc\host file
Code: Select all
<VirtualHost *:80>
    DocumentRoot C:/www/nonlive
    ServerName localhost.domain
    ServerAlias www.localhost.domain
</VirtualHost>
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby winfidel » 30. October 2005 03:00

WorldDrknss wrote:try connecting with http://localhost and make sure you disable Windows Firewall and open these ports in your software firewall
...
Well, that's my problem - I can't connect at all to that address, and Windows Firewall is disabled; also, Windows Firewall is my software firewall.

also set your router to use DMZ or again have these ports forwarded to your local ip address eg: 192.168.X.X
XAMPP is on my local computer, so I don't think I need to do anythng with the router, do I? Maybe later I would want to, but I'm assuming right now it's not an issue. But if I'm wrong, someone can tell me. I would think I could totally disconnect the network cable and still have it work as long as I have TCP/IP installed. ??

Did you open XAMPP Control Panel to make sure that Apache and MySQL where indeed running.
Yes, they are running, although I'm not certain MySQL is running properly; I'm trying to take it one step at a time, and concentrating on getting Apache to run first. The control panel says everything is running, but when I press "Admin" for Apache, it hangs waiting for localhost.

For MySQL, the control panel says it's running, but if I press "Admin", I get a window that says "Not found" on one line, then "Driver 3.51 not found" on another. It has some info on the left side, including my computer name and IP address. But, I'm waiting to worry about that later. :)

I appreciate your suggestions, and any others anyone might have.

Thanks again,

Marty Fried
Left coast, USA
winfidel
 
Posts: 3
Joined: 29. October 2005 22:18

Postby WorldDrknss » 30. October 2005 09:34

Try this:
Uninstall XAMPP
Delete the XAMPP Directory after you uninstall because it remains there

Download this version:
http://www.apachefriends.org/xampp-beta ... -beta1.exe

Install to C:\xampp

Once its complete try again, don't mess with any config files yet.
Im currently running this beta version and is much faster and has less problems then the latest version.
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby winfidel » 31. October 2005 06:44

WorldDrknss wrote:Try this:
Uninstall XAMPP
Delete the XAMPP Directory after you uninstall because it remains there

Download this version:
http://www.apachefriends.org/xampp-beta ... -beta1.exe

Install to C:\xampp

Once its complete try again, don't mess with any config files yet.
Im currently running this beta version and is much faster and has less problems then the latest version.
Well, I installed just Apache, and had the same problem. Then I tried it on another computer, and it worked right off, so I knew I was doing it right.

Then, I decided to uninstall some stuff on my system that wasn't on the other one, and that I didn't really use. After uninstalling Google desktop, I totally lost networking, and my computer started shutting down after a warning (there was a virus with similar symptoms, but I think I was clean). Anyway, I had to reinstall XP to recover from this, and now Apache installs with no problems, so I think I'm OK. I don't know if Google desktop had anything to do with the problem, or maybe it was some bad combination of software.

Perhaps I'll try the beta version you suggested, now. Thanks for your help and suggestions.

Marty Fried
Left coast, USA
winfidel
 
Posts: 3
Joined: 29. October 2005 22:18


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests