Page 1 of 1

XAMPP install on Windows 2003 Server

PostPosted: 26. October 2005 00:35
by captaintonka
Greetings All
I have come across a problem which I havent been able to work out and was hoping for some help!
I have trouble uploading files via html browser interface. This is the following configuration that we have for our server.

OS : Windows 2003 Server edition
ApacheFriends XAMPP (basic package) version 1.4.12

+ Apache 2.0.53
+ MySQL 4.1.9
+ PHP 5.0.3 + PHP 4.3.10 + PEAR
+ eAccelerator 0.9.2a
+ PHP-Switch win32 1.0 (von Apachefriends, man nehme die "php-switch.bat")
+ XAMPP Control Version 1.0
+ XAMPP Security 1.0
+ SQLite 2.8.15
+ OpenSSL 0.9.7e
+ PHPMyAdmin 2.6.1
+ ADODB 4.60
+ Mercury Mail Transport System for Win32 and NetWare Systems v4.01a
+ FileZilla FTP Server 0.9.4e
+ Webalizer 2.01-10
+ Zend Optimizer 2.5.7

The xampp root resides on D:/Apache/apachefriends/xampp opose to C: where the windows OS is installed. We initially had issues with the apache timing out when it was executed via xampp control panel, but over come this by installing it as a service. We have also installed mysql as a service and all is working fine. However if we try to upload any files via html interface it fails. I have checked the permissions on various folders such as the tmp folder refered to under php.ini and a temporary upload folder and that is set to 777. We have checked all configs such as absolute paths to install directories and all match the current install.
Your input would be much appreciated.
Many thanks in advace.

PostPosted: 26. October 2005 09:01
by nattl
Hi there,

try this: create a new directory for temporary files i.e. 'tmp' somewhere outsite apache-root and give the appropriate permissions to the apache-user. Now change the parameter 'upload_tmp_dir' in the php.ini to the directory you just created. After a xampp-restart the problem should be fixed.

I had a similar problem on a linux-server, the description above solved this problem. I hope it works on windows too.


PostPosted: 30. October 2005 22:49
by captaintonka
Hi nattl
Excuse my ignorance, been away and only got to see this reply. I would firstly like to thank you for the suggetion. We have given this a go and it still fails to work. I think it is mainly due to permissions but even though we confirm that the permissions are set to 777.
I will continue to troubleshoot, and advise. If any other recommendations, you input will be much appriciated.