Proper Settings for LAN???

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Proper Settings for LAN???

Postby Shizzle » 14. October 2005 17:31

I know that XAMPP is used for testing purposes or production type of tests, but I haven't got all of the individual software applications working properly if I do it manually, ie setting up apache, mysql, php, phpmyadmin, and all the others. So my question is how do I get XAMPP to work on a LAN? I tried just going to the http://ipaddress/webpage.php from a computer that is on the network and it is not able to view the page. Also I noticed that in the XAMPP control panel mysql keeps stopping and when I press start it just starts and stops so I figured that this was because a computer was requesting a connection to the webserver without permission.

I just downloaded the newest version of XAMPP for Windows to see if I have the same problem.

Also, anyone know of a good tutorial website or whatever on how I can setup websites like this:

http://localhost/
http://site2/
http://site3/ and so forth?

Thanks for the help in advance. :wink: :D
Shizzle
 
Posts: 11
Joined: 18. April 2005 04:30
Location: Beaverton, OR USA

Postby alucard01 » 21. October 2005 03:25

IMO, there is no specific settings needed to make other people connect to XAMPP.

My case is, when I have created a webpage, I tell other people what the URL is, e.g. http://192.168.1.1/mywebpage.php. And they can successfully connect to my website.

So, pls check if you have start your apache properly, or you can investigate apache log file for details.

About your mysql problem, check your mysql log file, or you can run the xampp-portcheck.exe to see if mysql port(3306) is being used by another application.

Hope it helps
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests