PHP & PostgreSQL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP & PostgreSQL

Postby cemplukcute2003 » 07. October 2005 02:44

I've installed PostgreSQL 8.0.
I've updated php.ini & unmark : extension=php_pgsql.dll
I've restarted the apache.
But i still got an error message :
Your PHP installation does not support PostgreSQL. You need to recompile PHP using the --with-pgsql configure option.
When i checked using phpinfo(), the postgresql module still not loaded.
Can someone show me how to recompile PHP in Xampp? So i can use the PostgreSQL work along with Xampp?
cemplukcute2003
 
Posts: 11
Joined: 06. May 2005 05:32

Postby Wiedmann » 07. October 2005 04:08

I've updated php.ini

Which "php.ini"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cemplukcute2003 » 07. October 2005 04:33

..\xampp\apache\bin\php.ini
Am i make a mistake?
cemplukcute2003
 
Posts: 11
Joined: 06. May 2005 05:32

Postby cemplukcute2003 » 12. October 2005 03:32

Is there anybody can help me, pls?
Cause i still can't find any solutions for this problem.
I really need help...
cemplukcute2003
 
Posts: 11
Joined: 06. May 2005 05:32

Postby cemplukcute2003 » 13. October 2005 04:13

I'm using windows XP SP2.
I've changed to php 4 using php_switch.
That means the directory that used for loadable extensions is :
extension_dir = c:\Program Files\apachefriends\xampp\php\extensions\
Is the directory correct?

But something strange happens.
It seems that the php.ini can't find any dll files.
I've tried uncomment the :
Code: Select all
extension=php_pdf.dll
extension=php_pgsql.dll
extension=php_imap.dll

But all of those modules didn't appear in the phpinfo(), although i've restarted the apache.

Can someone help me,pls?
cemplukcute2003
 
Posts: 11
Joined: 06. May 2005 05:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests