why Session save path unwriteable?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

why Session save path unwriteable?

Postby sastro » 22. September 2005 19:04

Dear all,

I am newbie here. I want to ask why my session save path is unwriteable? How to make it writeable and how to turn on or off my register globals?

I have installed apachefriends and when I tested to run a script installation, I got this :
- PHP version >= 4.1.0 Yes
- zlib compression support Available
- XML support Available
- MySQL support Available
- configuration.php Writeable
- Session save path .;c:\apachefriends\xampp\tmp, Unwriteable

I hope someone can help me.. I really need an answer for this.
Thanks in advance

Best Regards,

Sastro Gozali
sastro
 
Posts: 4
Joined: 22. September 2005 18:54
Location: Jakarta

Postby Wiedmann » 22. September 2005 19:30

- Session save path .;c:\apachefriends\xampp\tmp, Unwriteable

Remove the ".;" from the "Session save path".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sastro » 23. September 2005 03:44

Wiedmann wrote:
- Session save path .;c:\apachefriends\xampp\tmp, Unwriteable

Remove the ".;" from the "Session save path".


thanks for your reply. But where I can change it? what files do I have to change/edit?
and also how to change the register global on or off if I want? which files should I edit?

Thanks a lot

Sastro
sastro
 
Posts: 4
Joined: 22. September 2005 18:54
Location: Jakarta

Postby Wiedmann » 23. September 2005 10:25

For all PHP settings it's the same file (which is descriped in the PHP-manual also):
php.ini

(in "\xampp\apache\bin")
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sastro » 23. September 2005 12:17

Wiedmann wrote:For all PHP settings it's the same file (which is descriped in the PHP-manual also):
php.ini

(in "\xampp\apache\bin")


hi Wiedmann,
thanks again for ur reply.

I have changed the \xampp\apache\bin\php.ini file.
but still the same.

Then I try to install mambo,

- PHP version >= 4.1.0 Yes
- zlib compression support Available
- XML support Available
- MySQL support Available
- configuration.php Writeable
- Session save path .;c:\apachefriends\xampp\tmp, Unwriteable

Register globals is ON. I want to turn it off (as recommended)

here is my Php.ini :

; Argument passed to save_handler. In the case of files, this is the path
; where data files are stored. Note: Windows users have to change this
; variable in order to use PHP's session functions.
session.save_path= ".;c:\apachefriends\xampp\tmp"

then I change to

session.save_path= "c:\apachefriends\xampp\tmp"

still can't. Session save path is still unwriteable.

Please help me.
thanks in advance

Sastro
sastro
 
Posts: 4
Joined: 22. September 2005 18:54
Location: Jakarta

Postby Wiedmann » 23. September 2005 12:31

restart Apache
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 25 guests