New install on XP Home

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New install on XP Home

Postby scy » 15. September 2005 14:36

I have been using XAMPP on my old PC running XP Professional and very much like it. I have tried a new install on a new PC
using the installer. All goes smoothly but when I access localhost I get page not available. I have tried changing the directory
to C:xampp/ but did not make any difference. Tried reinstalling several times with no luck.

Am I just missing something obvious?
scy
 
Posts: 5
Joined: 15. September 2005 14:21

Postby redstar8 » 15. September 2005 14:43

Hi,
- try bringing up the XAMPP control panel and make sure apache is running.
- then run http://localhost
it should bring up the xamp page located in the htdocs dir.

I'm having a problem with connecting to mysql from PHP only on XP home but works fine on XP PRO ? getting: Fatal error: Call to undefined function: mysql_connect()

rs
redstar8
 
Posts: 8
Joined: 15. September 2005 05:35

Postby scy » 15. September 2005 15:17

all are running still get "page cannot be displayed error"

on the Service settings there is a check box for "Enable the XAMPP service" should this be checked? The individual ones beneth that are checked for Apache Mysql and FileZilla.
scy
 
Posts: 5
Joined: 15. September 2005 14:21

Postby redstar8 » 15. September 2005 15:58

Hi,

on my working XP / PRO

on the control panel settings:
- enable the XAMPP service is not checked
and Start these modules: Apache and MySQL are checked

on the control panel
- I'm not using the Svc checkbox on the list

I need to check my XP / home when I get home.
redstar8
 
Posts: 8
Joined: 15. September 2005 05:35

Postby scy » 15. September 2005 16:20

My Svc checkboxes are checked and Running.

When I am connected to the internet and put in localhost in IE I am immediatly redirected to a Dell Search Page with localhost as the search term.
Its a new PC - on my old one it would not make any difference whether online or not.
scy
 
Posts: 5
Joined: 15. September 2005 14:21

Postby redstar8 » 15. September 2005 20:34

- in ie / tools / internet options - try changing the default home page
- also run the XAMPP port checker in the XAMPP dir
- are you running any other kind of server ?

rs8
redstar8
 
Posts: 8
Joined: 15. September 2005 05:35

Postby scy » 15. September 2005 22:13

I changed the default to google anyway.

On the port checker

port 80 showes file path to apache.exe

I am not using any other servers unless there are any built in that I don't know about.
scy
 
Posts: 5
Joined: 15. September 2005 14:21

Postby redstar8 » 16. September 2005 04:22

Hi,

- try http://127.0.0.1/xampp/
- try http://127.0.0.1/

maybe something happened to your hosts file
redstar8
 
Posts: 8
Joined: 15. September 2005 05:35

Postby redstar8 » 16. September 2005 05:02

Hi,

I found my problem (a good posting on experts exchange) -
might be a good thing for you to verify too !

- I had to make sure the only php.ini was in C:\xampp\apache\bin\php.ini ( and in other xampp dirs that are just used to still support php4)
( I delete an old php.ini in c:/windows)

you can see which one apache is pointing to by using the phpinfo() function or from the xampp startpage / phpinfo
rs
redstar8
 
Posts: 8
Joined: 15. September 2005 05:35

Postby scy » 16. September 2005 20:29

Finally got it to work. new PC and needed to config IE

Tools > Internet Options > Connections > LAN settings

Checked "Automaticly Detect Settings" and

Use Proxy Server

Address Localhost Port 80

Although I reinstalled to C:/XAMPP/ using the self extracting zip.

Thanks for your help rs
scy
 
Posts: 5
Joined: 15. September 2005 14:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests