Problem with Apache installing XAMPP 1.4.15 for Windows

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Apache installing XAMPP 1.4.15 for Windows

Postby natasha » 08. September 2005 11:11

I installed XAMPP 1.4.15 for Windows using xampp-win32-1.4.15-installer.exe.
When went time to install Apache as a service, I had an error message
"Port 80 is busy!", and installation failed. Of course, I've IIS on port
80. I manually changed port to 8080 in httpd.conf.
When I try and start Apache using C:\Program Files\xampp\apache_start.bat,
I've the error "make_sock: could not bind to address 0.0.0.0:443".
If I try and start Apache from XAMPP Control Panel Application, it tells me Apache is started, but this isn't true ("Admin" and "Running" they're not enabled).
In effect, if I look in Control Panel\Services, Apache service is not
installed!
How to correct this problem?
Just a suggest for next version: when installing Apache, check ports 80
and 21 and leave user choose what ports to use if they're busy.
In effect I had the same problem with FileZilla, but changing port to 2121
in C:\Program Files\xampp\FileZillaFTP\FileZilla Server.xml resolved the
problem.
natasha
 
Posts: 5
Joined: 08. September 2005 11:01
Operating System: Win XP Pro / 7 Ult / 2003 R2

Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 37 guests