Just updated xampp, and security messed up mySQL!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Just updated xampp, and security messed up mySQL!

Postby Liath » 29. August 2005 08:41

Been a while, but I just updated xampp using the 7zip archive. Everything was running smoothly until I went to the security area in the /xampp/ section.

I set up mySQL with mysqladmin (for new root password), and changed the config.inc.php. phpMyAdmin worked perfectly. Then, being curious me, I checked out the security page and noticed it said the /xampp/ directory could be opened by anyone, so I did my duty and typed in a username and password to generate the .htaccess and .htpasswd files, just like a good boy should, then I **hit enter** instead of clicking on the "Make safe the XAMPP directory" button. Well, it seemed fine at first other than it said my SQL password had been changed instead... hrmm

Remembering the new username and password I'd set, I went back to phpMyAdmin, and neither the old, nor the new passwords would work! I get "Cannot connect to SQL database." Well, that is a drag. I'd spent about 3 hours updating my old htdocs files to be up to par, and modfying the various settings for the server using the config files. I cant seem to find the problem ANYWHERE! What exactly did the MYSQL root password security 'update' break, and how can I fix it without a lovely repeat of the utterly aggrivating config file editing? I'd really appreciate any help! :P

Thanks! Seems that this is the only nasty bug i've found so far, which is pretty darned good, considering there are so many updates. I remember the endless 'fixxing' I had to do to get my old xampp working the way I wanted it to. Big improvement!
Posts: 12
Joined: 08. May 2003 15:18


Postby Liath » 29. August 2005 09:10

Well, I figured a fix that worked. Seems that I coudln't find it by poking my nose around in mysql, so I unzipped just the mysql part of th 7zip archive and deleted/re-extracted the 'mysql' directory. This seems to have fixxed it, and now mysqladmin and phpmyadmin work again.

Hopefully this helps anyone else with this problem. And I'd suggest that unless ya know what is blowing up, or until the script developer repairs it, that you do not use the security password change part of xampp.

No bad intentions or will against the script dev, since, 'course I could just be a dense fool and missed what I needed to change, and it just 'appears' broken to me :P But warning just in case!
Posts: 12
Joined: 08. May 2003 15:18

Well, I *thought* it worked...

Postby Liath » 01. September 2005 00:44

Well, an update to the situation...

The above 'fix' worked until I restarted mysql... I don't see wha the heck the problem is! my.cnf hasn't changed, config.inc.php hasn't changed... but I cant use either localhost/phpMyAdmin or 'mysqladmin -u root password *secret*'.

Code: Select all
X:\xampp\mysql\bin>mysqladmin -u root password ********
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)

Code: Select all
Welcome to phpMyAdmin 2.6.3-pl1

(Cookies must be enabled past this point.)   
Cannot login to MySQL server

I know I'm using the correct passwords!

This has me stumped :|

Here are the steps that I used to install XAMPP:
Downloaded 7-zip package
Manually extracted to test xampp folder (on test box, fresh install+windoze updates)
Ran 'setup_xampp.bat'
tested with apache_start.bat and mysql_start.bat
Pages worked, stopped both of above
Started 'xampp-control.exe' and installed services
opened CMD, ran 'mysqladmin -u root password *****' (***** being real pass)
opened 'config.inc.php' changed these lines:
Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'cookie';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = '*********';          // MySQL password (only needed
                                                    // with 'config' auth_type)

Opened browser, tested phpMyAdmin, worked
Noticed 'security' page, went to it
changed xampp directory password
*accidentally changed mysql password (but same password I used for all other steps*
tested phpMyAdmin, did not work (above error)
opened CMD, ran all above commands again, and recieved above error
fumbled around for a few, slept, ate, etc.
extracted 'mysql' directory from 7zip, overwrote mysql directory
restarted MySQL, opened CMD and did above again
tested phpMyAdmin, it worked again.
installed e107, it worked fine.

Everything was running great, until I rebooted the test box to make sure services worked fine. Now I get the asme errors as before.

I'd really really prefer NOT to have to re-do the databases again, but if I have to, oh well... but I'd like to know what the heck is going on! What is mySQL doing while running (or shutting down, or restarting) that is screwing up??!?!
Anyone else having this problem?

Sigh... going nuts here.

oh, here are a few lines from my.cnf (which I didn't change from default...:
Code: Select all
# The MySQL client
# password       = your_password
port            = 3306
socket          = mysql

# Here follows entries for some specific programs

# The MySQL server
port            = 3306
socket          = mysql
Posts: 12
Joined: 08. May 2003 15:18

Hrmm... no replies... no-one else having problems?

Postby Liath » 04. September 2005 04:49

I'm guessing no-one knows what to do here? Still having the problem. I can change it to work fine for a while, but then as soon as the server reboots for maintenance or something else re-starts mySQL, it craps out again.
Posts: 12
Joined: 08. May 2003 15:18

Postby sampan » 18. September 2005 02:29

It's good to encounter someone else with the same problem as I thought I was going mad. I have spent many hour trying to figure what I have done wrong but have instead found many other people with the same problem and no fix (so far).

So far I think there are 2 workarounds:

1. Don't create passwords for root in MySQL
2. Use the previous version of XAMPP instead (v1.4.14)

By the way, I am running on Windows, not sure if Linux has this problem.
Posts: 2
Joined: 18. September 2005 01:34

Postby sampan » 18. September 2005 02:58

Bit of an update. Just upgraded my v1.4.14 to v1.4.15 on my test machine and the root password problem in MySQL seems to have disappeared.Even rebooting the machine does not cause any problems. Maybe this is the 3rd workaround / solution.
Posts: 2
Joined: 18. September 2005 01:34

Sigh... nothing...

Postby Liath » 28. September 2005 00:42

Well, an update on my end... I can't remember the steps, bot root works now... still having problems though...
I use e107 for a CMS, and I configured it just as I had before, and as long as I don't reload mySQL, it works fine. Then, after computer reboots for daily maintenance or I reload mySQL for some reason or another, it rejects the password for the account e107 works on. This is really really raelly annoying. Have to go into phpmyadmin and reset the password, then the site works fine. I imagine it has something to do with an issue I had before with a program ported from linux to windows... something with MD5 and some other encryption method. its the only thing I can think of :|
Posts: 12
Joined: 08. May 2003 15:18

Postby Liath » 29. September 2005 15:31

Wish someone 'in the know' would respond to this post.... This is really irritating. :(
Posts: 12
Joined: 08. May 2003 15:18

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests