A problem... 404 Document not found

Problems with the Windows version of XAMPP, questions, comments, and anything related.

A problem... 404 Document not found

Postby karasu-kun » 25. August 2005 04:22

Ok, I have just done stuff with virtual host... here is what I did:

(httpd configure file)
Code: Select all
#
# Use name-based virtual hosting.
#
NameVirtualHost *:80
#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
<VirtualHost *:80>
ServerName localhost
DocumentRoot C:\xampp\htdocs
</VirtualHost>

<VirtualHost *:80>
ServerName www.animelook.net
DocumentRoot C:\xampp\htdocs\animelook
</VirtualHost>
#


And here is the 'hosts' file (system32>drivers>etc>hosts):
Code: Select all
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
127.0.0.1       www.animelook.net


But I get a 404 Document not found! Error. Here is the folder tree, if that will help any:
Code: Select all
C > Program Files > xampp > htdocs > animelook > index.html


So there ya go I dunno what's wrong. The index.html is just a simple HTML doc with some blurbage- nothing else. Thanks for the help~
karasu-kun
 
Posts: 9
Joined: 24. August 2005 20:46

Postby Wiedmann » 25. August 2005 10:25

Code: Select all
C > Program Files > xampp > htdocs > animelook > index.html

Code: Select all
DocumentRoot C:\xampp\htdocs

Code: Select all
DocumentRoot C:\xampp\htdocs\animelook

Where is "Program Files" in your DocumentRoot directive?
(you should use string delimiter and forward slashs)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bugman » 25. August 2005 14:25

Hello,

To also avoid confusion, especiall if working for a live website i would change:

Code: Select all
127.0.0.1       www.animelook.net


to

Code: Select all
127.0.0.1       www.local.animelook.net


and also then edit your virtual host to look the same. As regards to your problem, as above

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby karasu-kun » 25. August 2005 20:18

Nevermind, I fixed it~ Apache would crash if I added 'Program Files' to the root, so I uninstalled/reinstalled to C:\xampp nd now everything works~ Strange... anyhow, thank's for all your help!
karasu-kun
 
Posts: 9
Joined: 24. August 2005 20:46

Postby Wiedmann » 25. August 2005 21:38

Apache would crash if I added 'Program Files' to the root,

Wiedmann wrote:(you should use string delimiter and forward slashs)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bugman » 27. August 2005 14:00

Hello

it always works better in the root drive, i am sure the instructions say to put it there too!

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby keepsedge » 28. August 2005 03:39

apache crashed because there was a space in the directory path "Program files" one would assume that youd put a %20 in there for the space.

I keep my htdocs at the root of my hdd c:/htdocs no problems that way
keepsedge
 
Posts: 33
Joined: 24. December 2004 11:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests