os 10048 error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

os 10048 error

Postby birdofprey » 23. August 2005 07:45

Anyone know exactly what I am suppose to be looking for in Services? I couldn't find IIS, and according to XAMPP FAQ it has to do with some kind of server I need to disable.
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 23. August 2005 15:50

Hi

In windows XP, goto run, type "cmd"

When the box appears, type in "netsta -a -o -n" and look in the pid column for 80

What ever that line is, you have to stop the service for it. To stop the service, right click on my computer, click on manage, then click on services. Somewhere in there is your service

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 23. August 2005 15:56

I don't see "80" in the PID column.
However, I do see 127.0.0.1:80 and on the PID column for that its 2312.

Is that what I am looking for?
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 23. August 2005 16:10

Well that indicates you have something running on port 80, which you already know

What windows version are you using.

Look in services for any of the following:
W3SVC,(world wide web publishing service), MSFTPSVC, the IISAdmin service. Stop any that you see

Do you have under services and applications a Internet Information Services? If so stop it too

Alternatively download this tool.
http://www.sysinternals.com/Utilities/TcpView.html
(download the free version at the bottom)

Run it with conjuction as it says, it will tell you which service is running on port 80, then you can stop it.


Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby Bugman » 23. August 2005 16:12

I forgot to mention, run xmapp port check located in your xmapp folder! That will tell you straight away!

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 23. August 2005 16:22

I am running win xp home w/sp 2.
i already check the services last night for all of the items you mention. None were there.

I have done the port check and it shows that

Apache http - port 80
Apache WebDav - Free
Apache Https - port 443

When I ran the Tcpview program it doesn't list anything using port 80.

do you require me to upload a screenshot so you could be understand it?
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 23. August 2005 16:24

Hello

Do this line first:
I forgot to mention, run xmapp port check located in your xmapp folder! That will tell you straight away!


And then just copy and paste what it says up here

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 23. August 2005 16:50

here is the screenshot, couldn't copy in ms-promt
Image
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 23. August 2005 16:56

I am guessing you want to run everything under xmapp? If so, i would quit running the mysql server 4 and allow it to run its version

Other then that, it should work!

When you type in (after stopping that other mysql working and getting xmapp mysql to run) http://127.0.0.1 what does it say?

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 23. August 2005 17:03

ok, i unistall the mysql and installed the mysql in xampp. 127.0.0.1 is still not working. when I pull it though the browser. Instead of loading anything, the loading process continues until I stop it with the stop button.
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 24. August 2005 08:35

Hello,

I forgot to mention yesterday, i never had much luch with Xmapp unless its in the root folder.

Change yours from program files to C:\xmapp and remember to run the setup_xmapp.

Then try again

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 24. August 2005 13:52

didn't work, same effect.
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 25. August 2005 14:17

Then I must admit, i am a bit lost.

All i can now suggest is that:

1) You check your host file, located in system32->Drivers->etc Open it in notepad, there should only be the one line of localhost there

2) Open it in another browser. E.g. IE6, firefox

3) Turn off all windows protection software, e.g. firewall, IE popup, other interfering software

Other then that, i am sorry, i don't know what else to suggest, apart from a complete reinstall of xmapp.

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby birdofprey » 25. August 2005 14:40

when u mention host file, which file is that to be exact?

I have anti virus running. Does that have anything to do with it?

In addition, I am getting my internet through a router, where I am using "port fowarding". Does that have anything to do with this too?

Is it normal not to see IIS Admin and the others in Services? Because, in almost all of the php/apache book I've read, all mentioned disabling IIS, but none were found in my Services menu.
birdofprey
 
Posts: 12
Joined: 23. August 2005 07:35

Postby Bugman » 25. August 2005 15:04

Hello

1) Your hosts file can be found here:
C:\WINDOWS\system32\drivers\etc

In the folder are several other files like network, protocol etc. Just open the "hosts" file using notepad. There should be only one line:

127.0.0.1 localhost

2) To double check everything, turn off your router (you wont be able to access the internet until you turn it back on, but should be able to access xammp). Also turn off the virus checker (shouldn't make a problem, but if its norton, you never know!), any other anti-internet program, and also check your firewall in XP. To do this goto
Start > Control panel > windows firewall
And then turn it off (if its not off already). Make sure you are disconnected from the internet before you do this.

3) With regards to IIs, XP home does not come with it built in, so no, it wont appear in your services unless you have installed it. If you did install but then uninstall it, it should no longer be there

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests