Page 1 of 1

Re-activating mysql after root password change...

PostPosted: 21. August 2005 10:27
by Agent86
I cannot seem to be able to get the status of mysql in the xampp console to show "activated" after I changed the password of the root and pma users. Everything but MySql and SMTP show "Activated." Please, someone help me.

PostPosted: 23. August 2005 15:56
by Bugman
You will need to stop it and start it again


PostPosted: 25. August 2005 05:24
by Agent86
Actually, I have restarted the server... the entire box. Several times. Restarting is not going to help. But, I notice it only happens after I go into the "Admin" area of mysql from the xampp control pannel. When I click on that link, it loads "winmysqladmin.exe." Once that loads, I get the logon box for mysql. This is where it gets messed up. I already have the passwords set through Xampp. When I go to http:\\localhost\security\index.php, I can see that all is secure except the "safe mode" setting. However, when I use the same logon (root), and the password I set in Xampp in the winmysql logon screen, mysql stops working. Even after I stop and restart the server. Additionally, no password works to get back into the mysql admin panels. Neither from Xampp admin, nor from the winmysql admin panel. Strange... I know. But, I'm a noob. Or, was a noob. I'm learning very fast. The only way I can seem to get it all to work is NOT to click on the Admin button beside the Mysql start button in the Xampp control panel. I have tried lots of different combinations during the setup phase. I've re-installed just mysql over and over to try the different settings, then Xampp over and over, and even winserver 2003 over and over thinking maybe it is because of some permission setting I couldn't locate. I even went back to IIS 6.0 for about an hour thinking I was going to give up on Apache. Bad mistake, I know.

Anyway, thank you for the pointer, but I'm not that much of a noob. :)
Any additional pointers would be greatly appreciated. I LOVE Xampp!!! I want ALL the buttons to be useful. It's killing me to not be able to click on it. I'm guessing it is another setting I have to manually enter into the code, but I don't know what one. Thanks again.