Mercury PHP Problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mercury PHP Problems

Postby bwall » 19. August 2005 07:19

I'm having problems with Mercury and setting it up using a php/html form to accept emails from my site and sending return. I'm running a server from my home and have that working, but email stuff is also new to me and need some help.

Here is the first problem that I was having, then I changed my php.ini and started mercury:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\apachefriends\xampp\htdocs\commentQuestions.php on line 51

Here is my current php.ini settings:
[mail function]
; For Win32 only.
SMTP = smtp-server.kc.rr.com
smtp_port = 25

; For Win32 only.
sendmail_from = info@robertwallaceii.com

Then I started Mercury from the xampp control panel:
Warning: mail() [function.mail]: SMTP server response: 553 We do not relay non-local mail, sorry. in C:\apachefriends\xampp\htdocs\commentQuestions.php on line 51

I have zoneedit and directUpdate running and working. In zoneedit I don't have a mailserver set up, because I'm mailForwarding all of my @robertwallaceii.com emails to my present email address.
I plan to change this later and set up my own smtp mailserver with mercury to accept email address from my site directly. For right now I want to get the mailForwards working.

My ports are forwarded on my router.

Thanks for any help
Bob :(
bwall
 
Posts: 7
Joined: 19. August 2005 06:59

Postby bwall » 19. August 2005 18:58

I've changed my php.ini file

sendmail_from =

to my email at my ISP and it won't work either.

Could this be because sendmail is not started or because Mercury doens't know who I am?
Thanks
Bob W.
bwall
 
Posts: 7
Joined: 19. August 2005 06:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: Altrea, mark.mcdonald and 59 guests