Accessing my IP from the Outside.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Accessing my IP from the Outside.

Postby Andy4Life » 10. August 2005 13:01

Hello all at Apache Forum! I have some problems with
xampp.
I have installed it all successfully, and changed all my passwords
and that is all secure.

I have a NETGEAR Router FR114P, and I want people
connecting through to my "AAC" (Automatic Account Creation - Used for online gaming) - Though, they can't connect through my Global IP, because I am behind a router and I do not know which ports to forward.

If some people can give me some help without risking the security of
my system, It would be great!
Thankyou..

Regards,
Andrew.
Andy4Life
 
Posts: 6
Joined: 10. August 2005 12:56
Location: Australia

Postby Andy4Life » 12. August 2005 06:17

Anyone..?

- Andy
Andy4Life
 
Posts: 6
Joined: 10. August 2005 12:56
Location: Australia

Postby sckoh » 12. August 2005 12:03

Your home is good.
I connected successfully.
http://www.andy4lifes-portfolio.aj-servers.com/
Image
User avatar
sckoh
 
Posts: 67
Joined: 01. March 2005 02:16
Location: Washington DC

Postby Andy4Life » 20. November 2005 11:28

It has been a while, and is anyone still around?
This matter is very hard to resolve.

Does anyone have the exact ports I have to forward
in order XAMPP to operate with a Router.

I have placed my index.php in the 'htdocs' of xampp under
C: and have installed it successfully.

I can connect through Localhost (127.0.0.1) but not
through my IP: 220.237.171.57

Thanks in advance.

Regards,
Andrew K.
Andy4Life
 
Posts: 6
Joined: 10. August 2005 12:56
Location: Australia

Postby PaulW » 21. November 2005 01:11

Take a look at http://www.iana.org/assignments/port-numbers. It's probably more info than you need. I think you may need to open port 80 on your router. I'm not very familiar with port settings, but it might be worth a try. Good luck.
PaulW
 
Posts: 13
Joined: 20. November 2005 17:20
Location: Norton, Ohio (USA)

Postby investor2006 » 29. November 2005 05:55

CAN N1 HELP ON THIS ISSUE

I have a adsl router and I have added the service called world wide web (http) tcp port 80 and still the webserver is not coming up.

what else has to be configured in order to see the server???

localhost works fine but not the real IP address.
investor2006
 
Posts: 2
Joined: 29. November 2005 04:03

Postby maikju » 29. November 2005 06:00

Did you forward port 80 to your internal ip?
maikju
 
Posts: 3
Joined: 29. November 2005 05:01

Postby WorldDrknss » 29. November 2005 18:10

Foward the following in your router and open up the ports in your firewall

ftp 21/tcp # File Transfer [Control] (XAMPP: FTP Default Port)
smtp 25/tcp mail # Simple Mail Transfer (XAMPP: SMTP Default Port)
http 80/tcp # World Wide Web HTTP (XAMPP: Apache Default Port)
pop3 110/tcp # Post Office Protocol - Version 3 (XAMPP: POP3 Default Port)
imap 143/tcp imap2 # Internet Message Access Protocol (XAMPP: IMAP Default Port)
https 443/tcp # http protocol over TLS/SSL (XAMPP: Apache SSL Port)
mysql 3306/tcp # MySQL (XAMPP: MySQL Default Port)
AJP/1.3 8009 # AJP/1.3 (XAMPP: Tomcat AJP/1.3 Port)
http-alt 8080/tcp # HTTP Alternate (see port 80) (XAMPP: Tomcat Default Port)

or enable DMZ on your router and again open up the ports in your firewall, and another thing to check is to see if your provider blocks port 80 if they do then you will need to change your port like like 8080 or 8000
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests