Appropriate Location/Settings for php.ini

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Appropriate Location/Settings for php.ini

Postby Philip G. Duffy » 04. August 2005 20:16

By this time I have several different versions of php.ini scattered over my disk (excluding the distributed and recommended versions). My last addition of Zend Studio Client/Server was probably done incorrectly by me such that I received a "You don't appear to have the mysql extension installed, exiting" message when I attempted to access the appropriate page using IE6 browser, which had worked previously. I reviewed Zend's "Adding Support for PHP 5" at www.zend.com/support/knowledgebase.php/ ... iew_only=1 which suggested that that extension_dir may be the problem.

When prompted during installation, I responded that php.ini was in the C:\Windows directory and that may have broken the XAMPP for Windows installation. I also have copies of php.ini in the following directories:

C:\PHP\BACKUP (39 KB)
C:\xampp\php (43 KB)
C:\apachefriends\xampp\xampp\php (43 KB)
C:\apachefriends\xampp\xampp\apache\bin (43 KB)
C:\Program Files\Zend\ZendStudioClient-4.0.2\bin\5 (1 KB)

According to phpinfo() the last is the active php.ini file. Apache is installed at C:\apachefriends\xampp\xampp\apache.

Whether I caused the problem or Zend Studio installation interferes with a prior XAMPP installation of Windows is less important than knowing how I can correct the situation. Can anybody suggest a correction so that I can reach my web pages through the browser?

Thanks.

Phil
Philip G. Duffy
Philip G. Duffy
 
Posts: 21
Joined: 10. February 2005 17:55
Location: West Chester, PA, USA

RE: Appropriate Location/Settings for php.ini

Postby hollystyles » 08. August 2005 12:42

My active php.ini is in this directory:

C:\apachefriends\xampp\xampp\apache\bin (43 KB)

I believe that's the one XAMPP uses from default install on windows.

I would rename the php.ini file in:
C:\Program Files\Zend\ZendStudioClient-4.0.2\bin\5 (1 KB)

and replace it with the one in:

C:\apachefriends\xampp\xampp\apache\bin (43 KB)

See if that works.
hollystyles
 
Posts: 2
Joined: 08. August 2005 11:48
Location: UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests