Some questions about XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Some questions about XAMPP

Postby chainzz » 28. July 2005 21:41

I am using XAMPP for a few days now, and it's working perfect for me. Thanks for making such an user-friendly compilation of Apache, PHP and MySQL :)
However, I have 2 questions:
1. MySQL doesn't run 99,9% of the time when I run it with xampp-control.exe, but it always runs fine when I use xampp_start.exe. What's wrong? And is it possible to hide xampp_start.exe from the taskbar when I run it? That's why I prefer xampp-control.exe right now, it doesn't fill up the taskbar.
2. I deleted all the files from htdocs, but when I put in my own files it doesn't list the directory in the browser, instead it redirects me to http://localhost/xampp/splash.php, but since that file doesn't exist anymore, it gives me an "Object not found" error. Can I configure XAMPP to list my directories?

edit: I just discovered that MySQL doesn't run with the xampp_start.exe :( It doesn't run with anything.
chainzz
 
Posts: 5
Joined: 28. July 2005 21:27

Postby xudzh » 28. July 2005 21:52

clear your cache for the second problem...

No idea for the first one

I never had problems with mysql, but my apache always crushes :(

XAMPP seems unstable to me.
xudzh
 
Posts: 8
Joined: 20. July 2005 23:16

Postby chainzz » 28. July 2005 22:20

I cleared my cache, and I can view the directory now, so problem number 1 is solved. Thanks for the solution xudzh :)
But problem number 2 still exists, however, I found out that I can run MySQL with mysql_start.bat. But that's the only way I can start MySQL, the rest doesn't work for me.
Another question: which files can I delete from /htdocs and which not?
Last edited by chainzz on 28. July 2005 22:22, edited 1 time in total.
chainzz
 
Posts: 5
Joined: 28. July 2005 21:27

Postby xudzh » 28. July 2005 22:22

Sorry, I only know a little bit about the Command Prompt and none about .bat files. :(
xudzh
 
Posts: 8
Joined: 20. July 2005 23:16

Postby chainzz » 29. July 2005 20:37

No suggestions anybody?
chainzz
 
Posts: 5
Joined: 28. July 2005 21:27

Postby alucard01 » 01. August 2005 12:35

Do you mean when you start xampp-control.exe and click mysql, it goes to "running" and then quickly go to "stop"?

if this is the case, are there any error log for this problem?

hope it helps
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51

Postby chainzz » 01. August 2005 13:22

Yes, that's my problem.
Where can I get the errorlog from?
chainzz
 
Posts: 5
Joined: 28. July 2005 21:27


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests